Skip to Content
0

Transaction OAYZ Depr Key field greyed out

Jul 31, 2017 at 04:04 PM

213

avatar image
Former Member

I am trying to create a new asset class , using same info from the older asset class by using transaction OAYZ for 01 and 20 my problem is the depr key (DepKy) is greyed out on both 01 and 20 depr areas

how do I open the Dep Ky field to enter the two keys above ???

Thanks

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Mark Whately
Aug 02, 2017 at 09:54 PM
1

Please execute t-code: AO21 and check layout 1000 in your system, see if ‘Class’ is flagged ON for depreciation key.


If it’s OFF, please flag it ON, save, and then try OAYZ again.

In case it’s already ON, please flag OFF -> save -> execute AO21 again -> flag ON -> save,

Share
10 |10000 characters needed characters left characters exceeded
MaDhU ReDdY Aug 01, 2017 at 04:51 PM
0

Hi

Depending on OADB setup, Depn Key can be adopted from other areas and hence field will be greyed out, but this should not happen to 01 area. seems wrong setup some where else. Can you try Activating all the areas, save and then check if field opens up.

Share
10 |10000 characters needed characters left characters exceeded
Tammy Powlas
Jul 31, 2017 at 04:51 PM
0

Are you in the configuration client? This is a configuration transaction

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Aug 01, 2017 at 12:20 PM
0

Yes, I am in transaction OAYZ in Development I am using the same info from a older class still in use, but somehow I just can enter the DEPKEY field

the deact button is automatically checked for both book and gasb depr . if I uncheck it and enter layout rule still wont open the Depky fields

thanks

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Aug 03, 2017 at 06:31 AM
0

This has to do with layout. The copy from parent option will copy the keys. If you enable child's independent key, that'll do.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Sep 08, 2017 at 07:58 AM
0

Hi Abraham,

Un-tick idle checkbox in OABD for dep area 20 and save. Make sure Deactivated checkedbox is unchecked in OBYZ

Thanks.

regards,

KK Lam

Share
10 |10000 characters needed characters left characters exceeded