Skip to Content
0

SAP Fiori Launchpad - Auto Logoff after inactivity

Jul 27, 2017 at 06:59 PM

576

avatar image
Former Member

Hi Friends.

We have custom UI5 applications running on Fiori Launchpad. We want the launchpad to logoff after some duration of inactivity . For this we set the parameters http/security_session_timeout and rdisp/plugin_auto_logout to 2 min ( for testing) but the session doesn't seem to get terminated at all. Pls note that we don't have any SSO solution in place and the Gateway is on the same box as ECC.

Would appreciate any suggestions.

Thanks

Santosh

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
avatar image
Former Member Aug 01, 2017 at 04:20 PM
0

Thanks Aarti and Sharath. We resolved the issue by changing the profile parameters.

From what i understand is to control the HTTP Security session on the ABAP side the parameter is http/security_session_timeout which basically tracks NO HTTP contact with the ABAP system based on the value assigned to this parameter.

The reason it didnt work earlier was because the parameter login/create_sso2_ticket was set to 2.

In this case i could see that when i go to TCODE SM05 i could see the active user session and after the timeout value the entry disappeared ( meaning the session ended as expected) But if you go to the browser and try to click on any other app/reload the page the application makes a HTTP request to ABAP system but instead of terminating the session the system issues an assertion ticket because the create_sso2_ticket is set to 2 and the session persists.

SAP Also recommends using the value 3 if you are using the security session management and expect the standard behavior.

Once we changed the value the logoff due to inactivity works just fine. Hope this helps.

Below URL for your reference.

https://help.sap.com/saphelp_nw73/helpdata/en/bb/1bcf2122fd4a76948816b1342f20d7/frameset.htm

Thanks

Santosh

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks for sharing the solution.

0
avatar image
Former Member Jul 31, 2017 at 10:38 AM
0

Hi Santosh,

I am not sure on second parameter which you guys are using-rdisp/plugin_auto_logout. I would suggest try using rdisp/gui_auto_logout. This should solve your problem.

Regards,

Aarti

Share
10 |10000 characters needed characters left characters exceeded
Sharath M G Jul 29, 2017 at 07:53 PM
0

You can try to log off due to inactivity from the UI5 application., if the Fiori settings are not logging the user off.

Regards,

Sharath

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Sharath,

Can you please elaborate more on your comment " from the UI5 application " ?

0
Sharath M G Aug 09, 2017 at 08:00 PM
0

There are options to trigger a log off from a UI5 application at particular period of inactivity.

If portal session timeout does not work, try to trigger it for the application running in the portal, which in turn should log off from portal.

Regards,

Sharath

Share
10 |10000 characters needed characters left characters exceeded