Skip to Content
0

Bi platform connection server issue

Jul 27, 2017 at 08:44 AM

114

avatar image

Hi guys,

we're are facing a strange issue with one of our BI platform enviroments. Everytime someone uses a universe in a report (Design Studio or WebI), the other users / scheduled instances of reports will somehow loose their connection and cannot be executed succesfully.

We noticed that the connection server will change it's "date modified" everytime a report with a universe is viewed. In other enviroments, the "date modified" of the connection server will only change if we change some configuration or restart the server. This is why we guess that this is a connection server issue.

Unfortunately, we haven't been able to narrow down the problem. There is no helpful error message, not even in the log file.

We checked that the licence key is valid. I've checked the connectivity service metrics, it says "Loaded" for all odbc entries. The standard watch for the connectivity server shows constantly value 3 and is not showing any problem. The connection server is constantly in running state, is enabled and health icon is green.

It seems that we have to open an incident with SAP to check on this problem - but before I give this a try, maybe someone has any helpful idea. I appreciate any hints. Thanks in advance for your help.

Regards,

Marius

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Jul 27, 2017 at 11:39 AM
0

Hi,

If I understand correctly, whenever you are accessing universe the connection server restarts and the instances fail. You can monitor the PID of the connection server to verify if it restarts. The PID changes only when a server restarts.
Is this for any universe you access or a particular universe. If all universes have issue, you may try to create a new connection server and test the issue.

-Abhilasha

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Abhilasha,

the PID of the connection server doesn't change - we just see that the date modified of the server changes and the report instances fail.

This is for any universe, even the e-fashion universe which is delivered by SAP with the BI platform.

I created new connection servers (Native Connectivity Service & Native Connectivity Service 32 bit), but the issue still appears.

Regards,

Marius

0
Ajay Gupta Aug 04, 2017 at 12:38 AM
0

Marius,

Do you have your server sized properly with enough memory, how much memory is allocated ? Have you split and sized the APS properly ? If the Connection Server is resting then you can't monitor the PID because it will change. You will need to monitor the ConnectionServer.exe associated with the server.

Regards,

Ajay

Share
10 |10000 characters needed characters left characters exceeded