Skip to Content
0

Sync Scenario Issue: HTTP response contains status code 500: PI 7.0 version -PROD URGENT

Jul 27, 2017 at 07:50 AM

85

avatar image
Former Member

Hi Experts,

We have Sync scenario where the sender is agile(FILE) and the receiver is ECC(Proxy)

Response message is failing with the below error in PI 7.0 version.

After checking the few threads i saw some solutions that we need to set the syncTimeout.

But i am not able to see the advanced tab option in PROXY receiver Channel in PI 7.0 version.

Also the module tab is disabled in PROXY receiver channel.

Note: this is existing interface and there are also successful msgs going.

Also the message size is very less.

Kindly let me know how to resolve this issue.

Do i need to add the module(syncTimeout) in sender file channel ? pls help

Regards,

SYED

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Evgeniy Kolmakov Jul 27, 2017 at 08:12 AM
0

Hi Syed!

Wouldn't you please explain in details how your Sync scenario with File sender is built. Do you use async-sync bridge?

By the way, in most cases the 500 Internal Server error means that there was an error(s) during message processing on server's side. You should check receiver system for error logs to find out what exactly went wrong.

Maybe you have more detailed error description?

Regards, Evgeniy.

Show 9 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Evgeniy,

Thanks for the reply..

Sorry the issue is with the receiver proxy..

can you please tell me how to fix this.

Regards,
NADEEM

0

And what is the issue?

0
Former Member

Issue is the same which i mentioned above.. response message failing due to time out.

Error:

HTTP response contains status code 500 with the description Internal Server Error Error while sending by HTTP (error code: 500, error text: Internal Server Error).

0
Former Member

Attaching the receiver Proxy channel screenshot.

I could not see the advanced tab and the module tab is disabled, so i cannot add the syncTimeout module.

We are using PI 7.0 version..

Pls help.

Regards,

NADEEM

file.png (29.6 kB)
0

And why do you think that it's a timeout error?

Regards, Evgeniy.

1
Former Member

Yes, because there is a time out for sync scenarios. Usually they set 5 mins by default for the Sync interfaces.

Now i need to increase the syncTimeout, but i am not able to achieve it in PI 7.0

thats the problem..

Do i have any other alternate ?

Regards,

NADEEM

0

Hi Nadeem,

It might not be a timeout issue and can be a proxy issue. Did you test your inbound proxy with the same payload locally in SPROXY transaction in ECC system? Is it giving the desired results?

You can try using HTTP destination instead of URL addressing in channel. Check the NWA logs to see if there is any detailed error. Also, as asked by Evgeniy earlier, can you detail how you designed File-Proxy sync scenario?

---Priyanka

1
Former Member

Hi Priyanka,

Thanks for your detailed response! but we have many successful messages before and after the failure message.

This is existing interface and not new development.

Regards,

NADEEM

0

Hi Syed!

So your message is processed and after 5 minutes you get error 500?

Regards, Evgeniy.

0