Skip to Content
0

Error using SAP Cloud Platform Web IDE

Jul 27, 2017 at 06:34 AM

460

avatar image
Former Member

As the title says, I'm having issues with the SAP Cloud Web IDE due to an error:

Server error occured. Copy and save your changes in an external file and close the error message.

This error appears after trying to save any changes to my code. I can see and edit everything fine but can't save anymore.

Before this, and sometimes after, another error pops up on the top right: "Failed to process problems"

I am using a trial (Europe - Rot) if this matters at all.

Can anyone help with this issue?

Thanks beforehand,

Carlo

Edit - I tried these solutions:

+ Refreshing Web IDE page
+ Logging off and back into the cloud environment
+ Using different browsers

Edit 2 - More light is shed by a new error when trying to access the GIT repository:
Request failed: Method Not Allowed URI: /orion/validateWorkspaceContent

It seems that we get denied by a system called Orion. Checked in the Chrome developer mode too. Same issue with the save request.

error.png (7.3 kB)
10 |10000 characters needed characters left characters exceeded
Former Member

More light is shed by a new error when trying to access the GIT repository:

Request failed: Method Not Allowed URI: /orion/validateWorkspaceContent

It seems that we get denied by a system called Orion. Checked in the Chrome developer mode too. Same issue with the save request.

I also edited the first post with this new info.

0
Former Member
Former Member

Orion is the base on which WebIDE is built.

I guess for now we should stick to the Personal Edition. I may take time for this to be solved...

0
Former Member

Facing the same problem today:

‎09‎:‎18‎:‎25 (codeValidationDAO) Request failed: Method Not Allowed URI: /orion/validateWorkspaceContent ‎<br>09‎:‎18‎:‎50 (Preferences) Could not save user preferences data. Reason: Request failed: Method Not Allowed URI: /orion/validateWorkspaceContent

Tried in Chrome and Edge, and I cleared the browser cache as well.

What can I do as well to solve the problem?

Thx.

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Moya Watson
Jul 27, 2017 at 07:44 PM
2

Hi all;

The team was alerted and has resolved the issue. Could you please check again and let us know if you still see any issues? Thanks and sorry for the inconvenience.

Show 9 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I can confirm that everything functions normally again, thank you for the feedback.

0
Former Member

It did work last Friday, so thank you for the intervention.

Alas, nothing is working right now:

0

Indeed, Nuno. The team has been working on resolving new/unrelated issues. You can keep in touch with the very latest on status by subscribing to:

https://sapcp.statuspage.io/

thanks and apologies
1
Former Member
Moya Watson

This link should really be somewhere more prominent.

I only found it through googling for this forum.

1

It's on our community topic page in the right-hand column --

https://www.sap.com/community/topic/cloud-platform.html

Where else do you think we should feature it?

thanks

0
Former Member
Moya Watson

I would suggest putting it on the cloud platform log-on screen and on the main cockpit. Probably in the Useful links section.

Or even better, a feed from there that goes directly into the cockpit that shows any problems right there on the cockpit or logon screen.

1

Thanks for the suggestion Carlo. That's a great idea, unless the cockpit is down itself -- but I can suggest to the cockpit team.

1
Former Member
Moya Watson

You're welcome, and thanks for forwarding the message!

0
Show more comments
avatar image
Former Member Jul 27, 2017 at 11:35 AM
0

Facing the same issues since yesterday. Have submited feedback via WebIDE as well.

Show 8 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I think the update yesterday broke something for us. I hope they will release a hot-fix for this.

Please let me know if you find something out, I'll do the same.
I hope we can get this worked out soon!

0
Former Member

Yep, seems it did.

I'll keep you posted.

0

Working for me since today, yesterday it was throwing the error

1
Former Member

I have started to get this error today, cannot use the WEB IDE to save changes or run apps.

Cheers

Andrew

0
Former Member

I also facing this issues beginning tis morning. :-(

0
Former Member

I am facing same issue :

Preferences) Could not save user preferences data. Reason: Request failed: Method Not Allowed URI: /orion/validateWorkspaceContent

for every action

Thanks,

Vijay

0
Former Member

I'm facing the exact same issue atm.
Also on Europe (Trial - Rot).

0
Former Member

I'm facing the exact same issue too. Just like Sandro Mösch.

0