Skip to Content
avatar image
Former Member

SQL Anywhere 12.0.1 for BI doesn't start because it's "not a valid Win32 application"

Dear all,

I came across a very weird problem. We have a BO BI Platform 4.1 SP6 Patch 3 running on SQL Anywhere 12.0.1.4127 (Windows Server 2012 R2) - well, as I noticed today, it's not running anymore ...

Evertime I try to start the "SQL Anywhere for SAP Business Intelligence" Windows Service, the following error occurs:

Windows could not start the SQL Anywhere für SAP Business Intelligence Service on Local Computer.

Error 193: 0xc1

In Windows Event Viewer (Windows Logs -> System) I find a corresponding error message that says:

The SQL Anywhere für SAP Business Intelligence service failed to start due to the following error: SQL Anywhere für SAP Business Intelligence is not a valid Win32 Application.

I really don't know when this issue started. There have been no BO updates or the like. I guess it might be caused by Windows updates!? But I couldn't find any information or solution or even a hint in SAP Support Portal or anywhere else ...

I already restarted the whole server several times and tried to repair the SQL Anywhere installation (Programs+Features, rightclick, repair) - it didn't seem like it did anything else then changing the timestamp ot the installation... anyway it didn't help at all.

The funny thing is, I can start the BI database itself via command line. But the Windows Service is required to start the BI SIA - so this doesn't help.

Maybe someone of you knows this situation and how to solve it?

Many thanks in advance for your suggestions

Best regards

Marie

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jul 25, 2017 at 02:01 PM

    For the SIA part - you can simply remove sqlanywhere from dependencies tab in CCM.
    If you're able to start sqlanywhere via command line , it'll allow SIA to start and work.

    As to original problem -

    Error 193 0xc1is occurred when the application manager system of windows fails to find the exact path of the .exe file of some program to run the service. Thiserroris not specific to any specialized software or application but it can come out with any application.

    See if this helps :

    http://www.fixerrs.com/2014/03/Steps-to-Fix-Error-193-0xc1.html

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 25, 2017 at 02:27 PM

    Oh my .... missing the forest for the trees...

    Thank you Denis! You didn't provide the solution itself but you gave me the right hint to find it on my own ;)

    There were no differences in the paths between registry and service definition BUT the quotes were missing at beginning and end of the exe-path. Because there are spaces in the path, Windows couldn't find the executable.

    problem: D:\Program Files (x86)\SAP BusinessObjects\sqlanywhere\bin64\dbsrv12.exe -hvSQLANYs_SQLAnywhereForBI

    no problem: "D:\Program Files (x86)\SAP BusinessObjects\sqlanywhere\bin64\dbsrv12.exe" -hvSQLANYs_SQLAnywhereForBI

    How could that be? Some time ago the service was edited via command line (sc config) to start with a limited amount of memory. Seems the quotes were missing since then. Why it still worked before, I really don't know - it shouldn't have!

    Thanks & regards

    Marie

    Add comment
    10|10000 characters needed characters exceeded