Skip to Content
1

Logfiles are not generated on BO Server (bo_trace.ini 4.1)

Jul 24, 2017 at 11:03 AM

67

avatar image

Hi,

ich have 3 BO Server with the same configuration. The TraceLog Service for the different servers and childs in the CMC is Unspecified. On two BO Servers logfiles are created in the default logging path, but not in the third BO Server. I found out that the bo_trace.ini is missing on the third server.

I have created one and then restarted SIA and tomcat. Unfortunately no log files are generated yet.

Does somebody has any idea?

Thanks,

Zaki

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Graham Farr
Jul 24, 2017 at 12:26 PM
1

Hi Zaki,

Did you copy the BO_Trace.ini from one of your working environments and ensure that the content is the same?

Are all the environments the same version? The BO_Trace.ini differs between 4.0 and 4.1/4.2

Lastly - the command lines of each server (seen in the servers properties) in CMC -> Servers specify a logging path. It's possible this may have been changed from default and your logs are being written elsewhere.

The logs also get written (by default) only if there is an assert message or an error. Have you tried setting tracing to high and seeing if any logs are then generated?

Occasionally if there is a problem with the BO_Trace.ini you may also see bo_trace.ini.err files generated in the same conf folder which may give some more indication.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Graham,

all 3 Servers have the same version. I have created a new BO_trace.ini on the third server and copied the content from the other servers BO_Trace.ini into the new one. The only difference was -I just see it- that I called BO_trace.ini instead of BO_Trace.ini. Is it important?

The logging path from servers properties and on the server is korrekt.

Thanks,

Zaki

0

It should be BO_trace.ini

0
Jawahar Konduru Jul 24, 2017 at 12:28 PM
0

Can you check if the path of the logging is missing in Server properties? Select servers from CMC, select any server, properties, Check in command line parameters, does it have path to logging folder?

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Jawahar,

yes, the logging path is korrekt.

Thanks,

Zaki

0
Denis Konovalov
Sep 19, 2017 at 05:52 PM
0

Did it ever worked on third server ?
How was it deployed ?

Share
10 |10000 characters needed characters left characters exceeded