Skip to Content
0

APIs failing since TLSVersion change

Jul 21, 2017 at 04:21 PM

116

avatar image

I had seen notices about new TLSVersion 1.2 and had added an Additional Property of TLSVersion=TLSv1.2 in all HTTP destinations, including those provided by SAP. However, starting today, all my APIs are failing with following message:

{"fault": {"faultstring": "Unable to identify proxy for host: s0004947755trial-trial.apim1.hanatrial.ondemand.com:9005 and url: \/s0004947755trial\/SI2\/Orders", "detail": {

"errorcode": "messaging.adaptors.http.configuration.ApplicationNotFound" }

}

}

Is anyone seeing this same issue and/or has found a solution on what else needs to be done here?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Elijah Martinez
Jul 21, 2017 at 06:48 PM
0

Hi Pise,

Another user has previously reported this (see: https://answers.sap.com/questions/262907/sap-api-hub-no-longer-works-on-trial.html ). I have also run into this on one of my own trial accounts. This is an issue currently restricted only to SAP CP Trial, but it is still vexxing nonetheless. I have reported this issue internally, and hope to see a resolution soon (probably not until after the weekend however).

This issue is strangely only affecting a minority of accounts, so it's great that folks like yourself let us know, and thank you for the additional information around TLS, to help diagnose the issue faster.

I hope to be able to get a resolution to you soon.

Regards,
Elijah

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Thank you for the response. That said, while the issue is being worked on, I'd like to ask another question. As mentioned in my post, I have added the TLSVersion parameter in all the HTTP destinations (where Proxy = Internet) which are essentially SAP Cloud Platform standard HTTP destinations. Do I need to retain that parameter or should I remove it?

0

Hi Pise,

The TLS Parameter was necessary only for HTTPS destinations, to test their compatibility with the update. That is to say that prior to the switch to 1.2, you could force the destination to use 1.2 in order to verify that it would not fail after the switch. Additionally I believe now that the switch has been made, you can use this flag in order to force a previous version, if it does fail and you need to use the older version in the meantime.

If you do not include the parameter, and it is an optional parameter, your destination will by default, now, use TLS v1.2 ; if you have it set for 1.2 you can feel free to remove it.

I hope this answers your question.

EDIT: Can you also please verify if your Trial APIM account is now working correctly? The issue should have been resolved over the weekend. If it has, please mark the question as Closed so that other users can see that it has been fixed.

Regards,
Elijah

1

Thank you. The issue was resolved from actions on your end. Appreciate the response.

0