Skip to Content
0

Crystal Report generates on dev box, but not web server

Jul 21, 2017 at 12:14 PM

25

avatar image
Former Member

I have a CrystalReportViewer control on an ASPX page. On my development machine the Crystal Report generates properly. However, when I publish it and run it on a web server I get the following pop-up screen. Entering in the password does nothing. The same screen just pops up again: (See attached uploaded image)

The datasource is configured in the .rpt file. So my code on the CrystalReportViewer is simply the following:

if (Request.QueryString["report"].ToString() != "")
{

ReportDocument doc = new ReportDocument();

doc.Load(Request.QueryString["report"].ToString());

CrystalReportViewer1.ReportSource = doc;

}

If it helps, some of the (more important looking) datasource properties in the .rpt file are as follows:

  • Database Type: ODBC (RDO)
  • DSN: plmprod
  • Server Type: ODBC - plmprod
  • Use DSN Default Properties: True

Also, I have the same ODBC/System DSN (named plmprod) setup on my development machine and on the web server. Using the "Test Connection" option they both test successfully.

I am not sure how to troubleshoot this issue. Nor do I know much about Crystal Reports.

What could be the problem that is causing the report to not generate on the web server?

capture.png (12.2 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Don Williams
Jul 21, 2017 at 03:31 PM
0

Change Tag to CR for VS.

Crystal Reports does not save the password.

Is the APpPool running in 32 or 64 bit mode? If 64 then you need to create the exact same DSN in the 64 bit ODBC Admin as a System DSN.

If the report has subreports you also need to set those log on properties as well.

And then you need to use Sessions and PostBack to keep the report in scope as well as putting the code in Page_Init.

Try searching first also.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jul 21, 2017 at 06:14 PM
0

Thanks for the reply. I created a 64 bit DSN and now it works.

I could not find a tag "CR to VS" or any variation and I did search first.

I appreciate your assistance.

Share
10 |10000 characters needed characters left characters exceeded