Skip to Content
0

Debugging XS - General SSLEngine Problem

Jul 20, 2017 at 02:34 PM

215

avatar image

hello gurus,

I am trying to debug an XSJS service (I have done this several times in other environments but no luck on this one).

My user has the debugging role and the server is allowed to debug (xsengine.ini file - developer mode).

When I open the debugging perspective, and try creating a new debugging session, I get an error stating: "Error in response from server: General SSLEngine problem"

I am using SAP HANA SP 12.2.06

I tried a suggestion: Window > Preferences > Network connections --> change Active provider from naitve to manual and got a different error java.nio.channels.ClosedChannelException, then if i try debugging again, I get the same General SSLEngine problem error

any other ideas are welcome.

** the service works and I get valid response when calling it - I just need to debug to see some behavior.

10 |10000 characters needed characters left characters exceeded

Hi Sergio,

Facing similar issue. Any pointers on how did you resolve the issue please ?

Thanks

0

I wasn't able to debug from HANA Studio, however, with the same settings, I was able to debug from the web work bench

host/sap/hana/xs/ide/editor

1

Hi Sergio, do you remember what solved the issue you had?

My customer is facing the same problem and I don't see any SAP note related to this.

Thanks,

Fernanda

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Michael Healy
Nov 16, 2017 at 05:00 PM
0

Hi Sergio,

Could you show what is showing in the relevant trace files when this occurs, ie:nameserver, indexserver and xs engine trace files?

Share
10 |10000 characters needed characters left characters exceeded
Sergio Guerrero Feb 14 at 07:38 PM
0

hi Fernanda, I am not sure I was able to solve this from HANA studio, however, my fix was to try to debug from the Web Workbench and it worked just fine.

host:port/sap/hana/ide/editor

set your breakpoint

launch your browser and it should hit the breakpoint

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thanks so much Sergio! I'll suggest that to the customer at least as a workaround.

1

Took me a while to let you know... but it worked! :-)

1