Skip to Content
avatar image
Former Member

Cannot create In-Memory Table in kerberized VORA 1.4

Hi SAP Community,

I want to create a simple table in Vora 1.4 using Vora Tools.

Until now I can create tables using Vora Relational Engine and Vora Disk Engine but when I tried with the In-Memory Engine, the operation threw an exception as it's shown below :

I looked into the vora-thriftserver log (vora-thriftserver.txt) and it gives not much further details.

However, as our Vora cluster use Kerberos, it seems obvious that it has to deal with a kerberos principal parameter but I don't know where I need to look into as I don't have any error with other Vora engines.

Thanks in advance for your help (I use HDP 2.5.3 for Hadoop side).

Yong-Eun KIM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jul 26, 2017 at 05:14 PM

    I have seen this issue when parameter 'spark.vora.principal' was set. The parameter name is incorrect. The parameter should be spark.v2server.principal and should point to the vora service principal. See current version of Vora Admin Guide at https://help.sap.com/viewer/p/SAP_VORA (the old version of the Admin Guide listed the incorrect spark.vora.principal)

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Franck,

      Thank you for your response.

      You are right, I was using the 1.0 version of the Vora 1.4 Admin guide and in it's latest version (1.2) the parameters concerning Kerberos and Vora are a bit different.

      However, even after renaming the parameter 'spark.vora.principal' to 'spark.v2server.principal' in spark-default.conf via Ambari interface, the issue still persists. I tried to put full qualified domain name or just the name of the vora principal into the value but the result is the same.

      I think that I will put this problem aside as In-Memory Engine is deprecated and other engines work.

      Thanks for your help anyway.

      Best regards,

      Yong Eun KIM