Skip to Content
0

How to get di-space-enablement-ui for SAP HANA Express

Jul 23, 2017 at 04:40 PM

354

avatar image

How do I get the di-space-enablement-ui for the SAP HANA Express edition? I do not see this under the apps? I get the error:

10 |10000 characters needed characters left characters exceeded

Please share which HANA Express version you are using and if the list of apps is complete you are showing (with xs apps).

0

Hi Florian,

Thanks for your follow up. Here is my SAP HANA Express Edition on AWS which I just launched a few days back:

HXE - SAP HANA, express edition (32GB)

SAP HANA Database 1.00.122.01.1470046197

SAP HANA XS Advanced Runtime 1.0.34.275394

Here are all of the steps I have taken to try to get pass the build error:

Here are my apps in the SAP space:

Thanks for your help in advance.

Regards,

Jay

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Florian Pfeffer
Jul 24, 2017 at 05:01 AM
0

You are using the HXE version based on HANA 1.0 SPS12. As far as I know, in that version the space enablement ui was not part of HXE (at least not in the VM version I have used at time that release was the newest one).

I would recommend that you use the HXE version based on HANA 2.0 SPS01 (the newest at the moment). Especially if you wanna use XS Advanced and the SAP Web IDE for SAP HANA.

Regards,
Florian

Show 7 Share
10 |10000 characters needed characters left characters exceeded

Hi Florian,

Which one should I try on CAL? I have tried the SAP HANA, Platform Edition 2.0 - which did not have SAP WebIDE for SAP HANA. So the I tried HANA Enterprise Edition. I do not see the HANA 2.0 SPS01 on the Cloud Appliance Library with my account.

Is there no way to get the build to work on the HANA Express edition on the AWS cloud at the moment? I did create another question for this -

HANA Express - Builder 'mtabuilder' is not available for workspace workspaceg5wib2oxjp9lp853

Here is another question without an answer resolution

Builder 'mtabuilder' is not available for workspace in SAP HANA WEBIDE

I think I should be able to get the build working on the current HANA Express on AWS.

Regards,

Jay

0

Unfortunately the HXE version offered by CAL is still based on HANA 1.0 SPS12. To my knowledge there is no newer version offered via CAL. If you wanna use a newer version you have to download it and install it on your local machine or on AWS manually.

0

Thanks Florian for your answer. I have downloaded the HANA Express from SAP but this is also HANA 1.0 SPS12. The latest HANA development class from Thomas Jung should work for the HANA Express 1.0 SPS12 version. The main thing that I am struggling with is trying to get the build working in order to start running nodeJS modules. Would you be able to also answer the other question I posted on the - Builder 'mtabuilder' is not available for workspace if you have a solution for that?

Regards,

Jay

0

Of course you have to download HXE HANA 2.0 SPS01, and not HANA 1.0 SPS12. Please just read the instructions on the download page.

0

Hi Florian - I will do that. But I am still waiting for someone to answer the question on how to get the build working for HANA Express 1.0 on SPS12 on AWS. This is the third environment now I am trying - just to get try to get nodeJS development working.

0

Hi Jay -

I'm with the same situation (same version... same error message).

Did you solved it?

Thank you,

Fer

0
Show more comments