Skip to Content

HANA Express 1 SP12 AWS SAP webIDE for SAP HANA- Builder 'mtabuilder' is not available for workspace

I am trying to create a Node.js Module using the SAP WebIDE for SAP HANA on my HANA Express Edition 1 SPS 12 on AWS. However, when i try to build the application, I get the error:

Build of jaytest_xsadvanced failed. Builder 'mtabuilder' is not available for workspace workspaceg5wib2oxjp9lp853.

HDB info shows the following:

I see the di-builder and the demo-web (which is the project I had created):

When I try to run the server.js node module, I get the error:

What are all the steps I need to do on SAP HANA Express to be able to build and run a nodeJS module?

Here is my SAP HANA Express Edition on AWS which I just launched a few days back:

HXE - SAP HANA, express edition (32GB)

SAP HANA Database 1.00.122.01.1470046197

SAP HANA XS Advanced Runtime 1.0.34.275394

I have the DEV_SPACE environment variable as SAP

hxeadm@sid-hxe:/usr/sap/HXE/HDB00> xs env di-core | grep DEV_SPACE

DEV_SPACE: SAP

I have the XSA_DEV as Space Developer in the SAP space.

hxeadm@sid-hxe:/usr/sap/HXE/HDB00> xs space-users HANAExpress SAP

Listing users in space "SAP" of org "HANAExpress" by role ...

role users

--------------------------------------------

SpaceManager XSA_ADMIN XSA_DEV XSA_SHINE

SpaceDeveloper XSA_ADMIN XSA_DEV XSA_SHINE

SpaceAuditor XSA_ADMIN XSA_DEV XSA_SHINE

Thanks,

Jay

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jul 24, 2017 at 08:44 PM

    Dear Jay,

    I saw you are working on this issue along with another question raised with the link below:

    How to get di-space-enablement-ui for SAP HANA Express

    Could you keep us informed whether this issue would be solved as well once you download and install HXE HANA 2.0 SPS01 successfully?

    Should you have further questions, please do not hesitate to contact us again.

    Best regards,

    Joice

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 24, 2017 at 09:53 PM

    I created the Role collections for WEBIDE_DEVELOPER and added this to the XSA_DEV user. Now when I try to build, I do not get the error - but the build just seems to hang and return a timeout. So it seems I am closer - but still not there..

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.