Skip to Content
avatar image
Former Member

Error posting IDoc to ECC [Fixed]

Hi Experts

I am new to SAP PI and am working on a cXML to IDoc scenario.

When I tried to post an IDoc to ECC via the testing tool, I get the following errors.
1. Adding control record to payload failed due to The Configuration for Sender/Receiver Partner Number/Port is incorrect. Enter proper values in Sender/Receiver Component

2. MP: exception caught with cause com.sap.aii.af.idoc.exception.IDOCAdapterException: The Configuration for Sender/Receiver Partner Number/Port is incorrect. Enter proper values in Sender/Receiver Component

3. Exception caught by adapter framework: The Configuration for Sender/Receiver Partner Number/Port is incorrect. Enter proper values in Sender/Receiver Component

4.Transmitting the message to endpoint <local> using connection AFW failed, due to: com.sap.aii.af.idoc.exception.IDOCAdapterException: The Configuration for Sender/Receiver Partner Number/Port is incorrect. Enter proper values in Sender/Receiver Component

I tried the following:

1. Disabled the control record and unchecked all the fields related to control record, sender and receiver in the advanced options tab of the IDoc communication channel

2. Checked all the fields mentioned above and mapped valid constant values to the mandatory fields in the control segments.

The above steps did not fix the error.

I also made sure that all the objects involved are Activated and my cache status overview is all green.

I am at a loss for what to check next.

Your help and guidance is appreciated

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jul 21, 2017 at 02:02 PM

    This doesn't sound like an issue with your mapping. Have you validated your IDoc adapter configuration yet? Has this particular connection every worked before?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Patrick

      My IDoc adapter configurations are good since I used a pre-existing channel for my development.

      I did not have any info maintained in the Logical System field in the adapter specific configurations of the inbound communication channel

      Thanks for your response

  • Jul 21, 2017 at 02:23 PM

    Hi Navin,

    Can you check after mapping if you are populating these below fields with correct values :

    SNDPRN , SNDPRT , SNDPOR , RCVPRN , RCVPRT , RCVPOR.

    And make sure you have enabled "Take control records from mapping " in your receiver channel .

    And note you need to validate this values with the one which you have configured in WE21 fro that particular IDOC in ECC.

    Br,

    Manoj

    Add comment
    10|10000 characters needed characters exceeded

    • Navin,

      There's no need of hardcoding .

      In your Reciever channel you have option " OverRide Control Records " here you can mention the field name with value.

      You can use header mapping which is present in Outbound processing tab in ico / receiver agreement too as well to populate control records.

      Br,

      Manoj

  • avatar image
    Former Member
    Jul 24, 2017 at 07:04 AM

    I was able to create an IDoc in ECC after I made the following changes

    1. Maintained the logical system in adapter specific configurations of the inbound communication channel

    2. Hard coded the values of the control segment

    3. Removed all of my custom mapping (at the end the only mapping in place was for the control segment)

    This fixed the issue.

    I am also suspecting that sending an invalid value to a field (eg. sending a character to a number only field) could have contributed to the issue.

    Thanks Patrick and Manoj for your quick response.

    Add comment
    10|10000 characters needed characters exceeded