Skip to Content
1

SAP Api developer portal no longer works on trial

Jul 20, 2017 at 09:23 AM

146

avatar image

Hi,

I had configured an api connecting to an on premise ABAP system via Cloud Connector.

That worked just fine until now. Suddenly I get the following errors all the time

{"fault":{"faultstring":"Unable to identify proxy for host: sXXXXXtrial-trial.apim1.hanatrial.ondemand.com:9005 and url: \/sXXXXXtrial\/sap","detail":{"errorcode":"messaging.adaptors.http.configuration.ApplicationNotFound"}}}


What am I missing ?

Nothing else was changed. The destination seems to work, the cloud connector is running.

Any help appreciated.


                
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

7 Answers

Best Answer
Elijah Martinez
Jul 20, 2017 at 05:44 PM
1

Hi Marcus,

Thank you for reporting your issue, it's good to hear when other people are impacted by issues.

There has been a few updates in the past week, including closer integration of the SAP API Business Hub (https://api.sap.com ) into the API Portal [See the new Discover button].

I have also encountered a similar issue as you are reporting on one of my Trial users. This is not a cloud connector issue, but possibly a Trial upgrade issue, as not all accounts are affected equally. I am following up on this right now, and will let you know what resolution is found.

Regards,
Elijah

Share
10 |10000 characters needed characters left characters exceeded
Marcus Schiffer Jul 20, 2017 at 02:34 PM
0

Thanks for the info.

I was even trying to set up the service from scratch again.

The catalog management servioce gives me a set of odata services, however when activatem tone of those, the same error appears. So cloud connector seems to be working.

Is there anything else that might have changed in the configuration over the last 2 weeks ?

I did not change anything in my settings since then and it worked perfectly.

Share
10 |10000 characters needed characters left characters exceeded
Marcus Schiffer Jul 21, 2017 at 06:41 AM
0

Thanks, for the prompt response !

I am using the Trial API hub to connect to our backend in a trial scenario.

Today another error occurs: Invalid URL. Hope the issue can be fixed.

Share
10 |10000 characters needed characters left characters exceeded
Ram Burugu Jul 20, 2017 at 01:26 PM
0

I tested my API on API Manager Portal and it works, just want to let you know that the services are working.

But mine is not through cloud connector, can you try a public API and see if is working.


api.jpg (147.6 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Jul 21, 2017 at 12:34 PM
0

Hey there,

I've been facing the same issue with my proxies as well.

Can't really do anything on the trial account right now.

I'll keep an eye on this thread for a resolution.

Thanks you

Share
10 |10000 characters needed characters left characters exceeded
Marcus Schiffer Jul 24, 2017 at 07:21 AM
0

Hi,

today it works again as usual.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Marcus,

Thank you for the update. There were some configuration changes made to the Trial landscape over the weekend. I am hoping this resolved the issue for users, as it has to my own account and yours.

If you are now fully resolved, please feel free to mark this question as Closed so that other users can see it is resolved.

Regards,
Elijah

0
avatar image
Former Member Nov 16, 2017 at 07:56 PM
0

Hey I am facing similar issue since long when I am trying to use my HANA XS Odata service in API management and receiving same error.
Is it related some roles or privilege to my trial user ?

capture.jpg

I have followed all the steps mentioned in the blog

https://blogs.sap.com/2017/08/07/connecting-and-exposing-apis-from-sap-hana/comment-page-1/#comment-399156

Thanks


capture.jpg (44.3 kB)
Share
10 |10000 characters needed characters left characters exceeded