Skip to Content

FTP Receiver adapter skip main payload

Hi

I have an ABAP Proxy -> PO sFTP adapter interface. When calling the Proxy i add a number of files as attachments (pdf, png etc.).

How can i set up the sFTP adapter in a way that only the attachments is stored on the FTP server - not the main payload itself?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jul 19, 2017 at 12:56 PM

    Jakob,

    if its SFTP then Use PayloadSwap bean and Don't tick "Keep Attachments"

    Br,

    Manoj

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 19, 2017 at 04:14 PM

    Hi Manoj

    Good point - but i have multiple attachments in the call and i don´t know the name and the type of the attachments.

    I.ex. i can have 3 attachments:

    filexx1.pdf
    filexx2.png
    filexx3.txt

    And i need to deliver all files to the FTP server

    Add comment
    10|10000 characters needed characters exceeded

    • Manoj K Jakob Steen-Petersen

      Jakob,

      Unfortunately your FTP adapter can handle only one file at a time i.e mainpaylaod so only the main payload is dropped at target side now the only way to make your attachment as a mainpayload is via swap bean which replaces only one attachment at a time. So through single channel it not possible you to drop all the attachments. The other option is using ZipBean but note ZipBean includes all the attachments along with mainpayload too.

      Br,

      Manoj

  • Nov 29, 2018 at 07:08 AM

    Hi Jakob,

    Were you able to achieve the above requirement?

    I have similar requirement. Let me know your solution.

    Regards,

    Ashish

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 29, 2018 at 08:08 AM

    Hi Ashish

    Actually no - we ended up with a solution who places the Payload in a file called just "att". This file is overwritten each time a bunch of attachments are send. So the receiver accepted that there will always be one file called att which can be ignored.

    Not the nicest solution, but we needed to move further :-)

    Add comment
    10|10000 characters needed characters exceeded