Skip to Content
0

Scripted Calculation View Losing Records on Output

Jul 17, 2017 at 10:38 PM

25

avatar image

Hi,

We have ECC6 running on Hana DB 1.00.097 using analytic views for operational reporting.

I have a scripted calc view (......it truly is necessary as the transaction data has to be looped through recursively) where the records selected and organized for output are not all in the results of the view. Initially I thought that this might be related to the definition of the view so I also recreated the scripted view as a regular stored procedure and encountered the same result.

I traced the procedure in debug mode using breakpoints and I can see the records in the variable that the procedure outputs right before the END statement and the variable contains all the records that I would expect. HOWEVER....when I run the procedure and receive the output the results are missing some records.

I realize that our HANA environment is quite far behind on SPs and I am wondering if what I am encountering is a calc engine bug that has been fixed in a later SP. Has anyone encountered similar behaviour? I search the SAP Notes but could not find anything that matched this scenario.

Any feedback or experience that could be shared would be appreciated.

Thanks, Mel

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers