Skip to Content
0

While modifying the SAP BO 4.2 update the BO services including CMS were accidentally deleted.

Jul 17, 2017 at 05:34 PM

205

avatar image
Former Member

While modifying the SAP BO 4.2 update the BO services including CMS were accidentally deleted. How to restore ?
We updated the SAP BI 4.1 to SAP BO 4.2 SP4. After successful installation and update to BO 4.2 SP4 , we needed to do some modifications. Unfortunately, modification went wrong and the CMS and associated SIA got deleted.
Now when we try to repair , it asks for an existing CMS which does not exist anymore .

Is there a way to restore to the previous state ?

Kindly help.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Matthew Shaw
Jul 18, 2017 at 08:13 AM
1

You'll need to have a valid CMS database, so your first task will be to install that and restore the database to it. Regards, Matthew

Share
10 |10000 characters needed characters left characters exceeded
Denis Konovalov
Jul 17, 2017 at 05:50 PM
0

if you have CMS DB and binary backups, you can restore.
Repair will not help, since you removed the CMS/SIA, you need to run Modify and add them back in.
If it asks for existing CMS just cancel and it'll continue.

Show 5 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Dear Denis

Thank you for quickreply.

Yes I have my cms db backed up . When I run the modify , it does not continue after I cancel its existing cms request .

But it continues in case of repair after I cancel it .

Should I continue with this repair option skipping its request for existing cms ?

0

repair shouldn't work in case you're describing - how about simply creating new SIA in CCM ?

0
Former Member

I will check it tomorrow. I don't have access right now.

0
Former Member

Denis , the system database was based on Sql anywhere.It has also been uninstalled. I can access CCM and when I try to make a new SIA, it asks for cms db which also does not exist.

I tried with modifying the installation but it does not allow moving forward without giving CMS logon credentials ( which is also deleted).

I am not sure if there is any way around except uninstalling everything and reinstalling.

What do you think ?

0

in this case you need to re-image and re-install.

0
Ajay Gupta Sep 14, 2017 at 01:49 AM
0

Karrar,

Follow link below to restore / recreate the SIA and all the Servers.

https://blogs.sap.com/2015/08/24/how-to-restore-bi4-from-frs-cms-backup/

Regards,

Ajay

Share
10 |10000 characters needed characters left characters exceeded