Skip to Content
0
Former Member
Jul 05, 2007 at 03:28 PM

run report Propagation of Properties

16 Views

Hello,

I want to run the report "Propagation of Properties" in a CM FSDB repository for a predefined property : "business_unit_optional"

When I run the report on my "/SEPData/Restricted/Internal/" folder (that is a FSDB CM Repository) I've the following error :

"

error executing: /reporting/reports/Content Administration/Mass Operations/property/1183648832033.xml(com.sapportals.wcm.service.reporting.ReportInput@30df90bc) - java.lang.NullPointerException at com.sapportals.wcm.repository.manager.reporting.reports.PropertyPropagationReport.getPropagationInfo(PropertyPropagationReport.java:586) at com.sapportals.wcm.repository.manager.reporting.reports.PropertyPropagationReport.getReportInfo(PropertyPropagationReport.java:539) at com.sapportals.wcm.repository.manager.reporting.reports.PropertyPropagationReport.execute(PropertyPropagationReport.java:523) at com.sapportals.wcm.repository.manager.reporting.reports.PropertyPropagationReport.execute(PropertyPropagationReport.java:482) at com.sapportals.wcm.repository.manager.reporting.monitor.ReportComponent$ReportWrapper.execute(ReportComponent.java:160) at com.sapportals.wcm.service.reporting.scheduler.ReportScheduler$Runner.run(ReportScheduler.java:197)

"

and the properties are not updated.

Then I ran the report on the "/documents" folder, this is working fine.

The only difference between the two folders is that my CM repository is "Version Enable" and not the "/documents".

So I disabled the versioning in my CM repository, and the properties are properly updated.

This is not a solution, as I do have a hierarchy of about 5000 folders, and I can't envisage to manually disable the versioning for all folders and then reanable them.

Did someone have an idee ?

Thank you for your support.

Vincent