Skip to Content
avatar image
Former Member

SDM Configuration Problem

I am not able to add J2EE engines in the SDA/SCA deployment option in NWA ->Administration->Mobile Infrastructure->Mobile Archive Converter. Whenever I try to add a J2ee engine and SDM port config, I get a null pointer exception. Also the password box is disabled. I have done a local installation (without defining any SLD). Also i tried a workaround for this using the Mobile Components page. When I Undeploy components, I give the J2EE details with SDM port and password and checked the Save Details option, but it does not save the J2EE details. Can anybody help me out?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

10 Answers

  • Best Answer
    Jul 06, 2007 at 09:07 AM

    Hi Veer,

    Hot fix is availble in following location please download it form here and deploy it using SDM.

    https://sapmats-de.sap-ag.de/download/download.cgi?id=WI3KLUU68UPDPXSPR3ZTO86S2N3HHEUTK6I9SS7MTEFX44DY7B

    SDM you can find -: J2eeInstDir\usr\sap\instancename\serverinstname\SDM\program\remotgui.bat.

    start the bat file login with credential, select deployment tad, add the zip or sca file, and say deploy.

    Regards,

    Satyendra

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 07, 2007 at 08:29 AM

    I gladly would, but I am not the original poster of this thread.

    Maybe it should be opened as a new thread with a better matching headline, since this problem probably will happen to other people.

    Or is this bad manners to double post?

    With the deployment of NWMADMIN20P_2-10002889.sca it now seems that all my monitoring works ... still need to test a bit.

    Sorry, I am pretty new here 😉

    Andre

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      i dont think there is a problem with re posting for better clarity to others.... 😊 I will give the answer there again and you can give me points.... 😊

  • Jul 05, 2007 at 02:18 PM

    Hi Veer,

    Pwd field will be only enabled if there is already an entry for the J2ee_engine in the middleware .

    If you are deploying the sda first time then you need to first add the J2ee_engine details.

    After adding it select the J2ee_engine from the engine details table available on the same UI, Now you can find pwd field enabled.

    Deployment steps.

    1. create sda.

    2. click SDA/SCA deployment.

    3. Click on add button and then save button.

    4. select the j2ee_engine from the table.

    5. Enter pwd and say next.

    6. select the sda to deploy.

    7. say start deployment.

    8. Do a reload.

    Regards,

    Satyendra

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 06, 2007 at 05:45 AM

    Hi Veer,

    Check middleware table MEMGMT_J2EE_LIST.

    Is there any entry J2eeHost and port on it.

    Open MobileArchiveConverter UI of NWMAdmin, Click on "SDA/SCA

    Deployment" button.

    Check whether the same entries are getting listed in the table

    available on J2ee-EngineDetails UI.

    If not then at the same time can you check in NWMAdmin is displaying any

    message on top on ArchiveConverter UI.

    Note message will be displayed on the ArchiveConver UI not on the

    J2ee_engine details UI. Please don't close the J2ee_engine details UI,

    and check for the message.

    Regards,

    Satyendra

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I have two entries of the same engine. I get the message "Connection handle is already closed and no longer associated with a managed connection" Should I delete the second entry? Also no entries are displayed in the UI.......... And hey.....table maintenance is not allowed for the table ......I cannot modify anything with the table

      Message was edited by:

      Veeraraagavan R

  • Jul 06, 2007 at 06:30 AM

    Hi Veer,

    Can you also try to access some other links (DeviceMaintenance, ParameterSet)and see whether the same message is getting displayed there.

    I think this is the problem in J2ee_engine.. if you deploy the SAPJRA.sca for sp21 then it will solve the problem.

    Regards,

    Satyendra

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      they r also having the same problem....By the way I am not able to find SP21 of setupjra.sca. Can u give me the SMP path/link for the same????

  • avatar image
    Former Member
    Aug 06, 2007 at 03:24 PM

    I have the same Problem with the configuration of the Monitor JCO Destinations

    > Select Maintain JCO Destination

    >

    > Create both destinations one by one. (You will find the status RED -> select

    > create to make it GREEN)

    >

    > metadata --> dictionary data

    > modeldata --> application data

    > Select MIDDLEWARE in the dropdown and enter the credentials.

    In Step 4.2 the drop downlist has "<SAPID> <hostname>" and the other input fields are disabled. At the end of the process "Finish" I get the following error messages:

    MsgServerName is not defined.

    SystemName is not defined.

    LogonGroupName is not defined.

    I have no idea how to set them.

    Any ideas?

    Thanks, Andre

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      If you have a running SLD, then go to http://<host>:<port>/sld. Then click on "Technical Landscapes" Then Click on "New Technical System", add the necessary details about your middleware ( or backend if you want to have a backend in the landscape). Now once this is configured, you can select the Message Server. Also you need to check if the Group "PUBLIC" is assigned to your middleware/backend. Use the smlg transaction to check the same. Once you are sure that your instance is assigned to GROUP PUBLIC, Press F6 or click on the "Message Server Status Area" icon (purple in color). Here you must see an entry in "Logon Favourite Storage" with your instance and group PUBLIC. Hope this solves your problem

      Message was edited by:

      Veeraraagavan R

  • avatar image
    Former Member
    Aug 07, 2007 at 08:02 AM

    Thanks!!! This helped a lot but there is still something missing in my configuration.

    I could now create both Monitor JCOs. The Status light is green. But when I test either of them I get the following error:

    com.sap.mw.jco.JCO$Exception: (102) RFC_ERROR_COMMUNICATION: Connect to message server host failed Connect_PM TYPE=B MSHOST=misapdev GROUP=PUBLIC R3NAME=MID MSSERV=sapmsMID PCS=1 ERROR Group PUBLIC not found TIME Tue Aug 07 09:57:30 2007 RELEASE 640 COMPONENT LG VERSION 5 RC -6 MODULE lgxx.c LINE 3541 DETAIL LgIGroup COUNTER 1

    So "Group PUBLIC not found" is the important part, I guess. I created the Group in the User-Management of NWA. probably the wrong place. Still the same error message.

    Cheers, Andre

    So how do I create such a group?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 07, 2007 at 08:16 AM

    Got it ...

    In Tx SMLG I forgot to SAVE the new assigment the first time.

    Now the test works.

    This should make it into the Installation Guide ...

    Trying to assign points, but not sure whether it will be possible, since this is not my question and it was already marked as "answered".

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 07, 2007 at 08:19 AM

    i have made the question unanswered for u to give me points

    Message was edited by:

    Veeraraagavan R

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 07, 2007 at 08:40 AM

    .

    Add comment
    10|10000 characters needed characters exceeded