Skip to Content
0

Parameter DATABASE_SID must not be empty for a connect to a multiple-container system!

Jul 18, 2017 at 11:24 AM

180

avatar image
Former Member

Hello SAP Community,

I am facing the below error when i install S4HANA 1610 with SWPM 1.0 SP12 on HANA 2.0 SP01 .

Before starting SWPM for S4HANA 1610 installation, I have installed HANA DB using HDBLCM tool which comes with HANA 2.0 SP02 software .

SWPM error out with message "

Tue Jul 18 14:00:51 IST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Parameter DATABASE_SID must not be empty for a connect to a multiple-container system!"

swpm-error.png


But HANA 2.0 SP01 is comming with MDC installation default . I can connect to SYSTEM DB & TENANT DB VIA HANA STUDIO.

PAS Host - 10.xxxx- SAP SID - SH1 ( In SWPM , i have provided SAPSID = SH1 , DBSID- HDI)

HANA DB HOST - DB SID - HDI ( Both for SYSTEM, Tenant) ( During HANA DB install using hdblcm, I have provide DBSID- HDI)

Please kindly share a solution if you have come across.

Thanks & Best Regards

Satish

swpm-error.png (64.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
avatar image
Former Member Jul 19, 2017 at 06:28 AM
0

Hello SAP Community

Thanks for the support, I am able to fix the issue.

Below are the learnings

Reason 1 : From HANA 2.0 , we need to keep both 3<instance>15 - tenant, 3<instance>13 system db ports open via SUSE LINUX firewall usign YAST tool . we can easily specify the exact port number in YAST tool under security network fields

Reason2 : If 3<instance>13 is some how not open , SWPM will consider the HANA DB as single container and proceed further .

Reason3 : Once 3<instance>13 is opened, SWPM will give new screen for tenant DB sid and password for MDC because its able to connect to SYSTEM DB. Hence we need to get these screen mandatorily for Multitenant setup

To overcome issue of "

Parameter DATABASE_SID must not be empty for a connect to a multiple-container system!"

PLEASE ENSURE we open the ports 3<instance>15 - tenant, 3<instance>13 system db ports open via SUSE LINUX firewall usign YAST tool.

and freshly start SWPM . The SWPM 1.0 SP20 must detect DB HOST, TENANT & SYSTEM DB seeking passwords . ( 3) screens must appear mandatorily. else SWPM will consider it as single container . Unfortunately SWPM does not throw error that 3<instance>13 system db is not open rather it throws above error .

Hope this info helps other SAP BASIS administrators .

Best Regards

Satish

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Congrats for solving the issue and thanks for sharing the solution!

Best regards

Bartosz

1
Bartosz Jarkowski Jul 18, 2017 at 08:00 PM
0

Hi,

why are you using SWPM SP12 when there is SWPM SP20 released?

Bartosz

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Bartosz , Sorry for the typing mistake . i am using SWPM 1.0 SP20 ( Latest patch) .

I get the error message - SWPM error out with message "

Tue Jul 18 14:00:51 IST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Parameter DATABASE_SID must not be empty for a connect to a multiple-container system!"

Before starting SWPM 1.0 SP20 , i have installed HANA DB 2.0 SP01 using HDBLCM gui

Please advice any solution for this issue .

Best Regards

Satish

0