Skip to Content

HXE installation di-core start {"error":"invalid_token","error_description":"unauthorized"}

Hello Colleagues,

installing hxe.tgz + hxexsa.tgz. SUSE 12SP1

after an couple of hours last words of setup_hxe.sh:

...

Adding role 'OrgManager' to user XSA_ADMIN in org "HANAExpress" ...

OK

Deploy di-builder for WEB_IDE...

Waiting for di-core to start..................

{"error":"invalid_token","error_description":"unauthorized"}

>

#

What kind of token?

XS installation log file xs_install_components.log is full of such messages:

7/18/17 8:43:49.404 PM [APP/1-1] ERRAuthorization check for user [XSA_ADMIN] is completed: Not Authorized#

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jul 18, 2017 at 10:41 PM

    Hello Dmitry:

    It may help the diagnosis if you share the logs. Can you try zipping up the installation logs and share them? The logs are located in the /var/tmp directory and begin with "hdb". You could tar them up with the following command:

    "tar -cvzf hdblogs.tgz hdb*"

    If that proves too big to upload, just tar up the contents of the most recent HXE install directory "/var/tmp/hdb_HXE_hdblcm_install_<date>" and the "hdbinst_XS.log" and "hdbinst_XS.msg" files.

    Can you also share information about the operating system version you are trying to install on and the version of HANA Express. The HANA Express version information can be found in the file "/usr/sap/HXE/SYS/global/hdb/hxe_info.txt"

    Can you also share the following logs if they exist:

    1. /usr/sap/HXE/HDB90/hxehost/trace/xscontroller_0.log from the trace directory
    2. access_log-controller-route-api.log in /hana/shared/HXE/xs/controller_data/controller/router/webdispatcher/logs

    Regards,

    Carl

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Dmitry:

      I don't think there's any remote communication going on at that time in the setup. If you have opted in to telemetry there will be times when the system tries to transmit to the back end telemetry server, but that would be a different error and at a different point in the process.

      Nevertheless, I've shared your information with the installer team so we can keep an eye out if this happens again.

      Thanks for using HANA Express. I'm glad its' working for you now.

      Regards,

      Carl

  • avatar image
    Former Member
    Jul 22, 2017 at 12:29 AM

    Please try to do "xs logout/xs login" with XSA_ADMIN user before deploying di-builder to see if it solves your problem.

    After adding role to XSA_ADMIN user, we need to login/logout with "xs logout/login" to give XSA_ADMIN user a chance to get the role assigned.

    Regards.

    Yiqing

    Add comment
    10|10000 characters needed characters exceeded