Skip to Content
author's profile photo Former Member
Former Member

How to make a forced timeout in MDM Workflow?

Hi, all!

I have a workflow that has two consecutive steps:

'Syndicate' -


> 'Stop'

Workflow deals with checked out records. 'Stop' step has Record Checkout = 'Roll Back'

Syndication actually takes place not the moment when step 'Syndicate' is executed but in some period - I suggest this period is related to polling cycle of Syndication Server ('Auto Syndication Task Delay' property in mdss.ini).

So when actual syndication takes place, workflow has no records because they has already been rolled back by 'Stop' step. As a result, since current workflow has no records, syndicated file contains all records of repository.

My question is - can I give a delay about 10-15 secs after 'Syndicate' step finishes and 'Stop' step begins for these steps to come one after another as it is in the workflow?

Best regards,

Vadim Kalabin

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 17, 2007 at 11:32 AM

    According to your workflow when u do stop that time only your record get syndicate.

    before that record are waiting to complete the workflow & ready for syndication when moment you click on stop that means workflow get completed and record get syndicated.

    you can delay the syndicate task as many second you want for that reason you need to change in mdss.ini <b>Auto Syndication Task Delay (seconds)=0</b> you can give sec as many you u want if you give 60 sec that means 1 min. again restart the MDM syndication server.

    according to your workflow moment you click on stop that means workflow get completed but still not syndicated that is auto sydication it will wait still time you define in mdss.ini file for e.g is you set 10sec in mdss.ini then after 10sec your recrod get syndicate still that time your workflow get completed and record remain in your repository after 10sec recrod get syndicated

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 19, 2007 at 07:46 PM

    Hi,

    To Over come the situation like you,we did the work around like below.

    1) Create a Field called Status in Main Table - Table Flat Lookups

    2) Populate Flat lookup Values like Ready for syndication,Not Ready for syndication and so on to the Flat lookups

    3) In Mapping in MDM Syndication - Go to Free Form Search - Give Status = Ready for Syndication .

    4) Remove the Syndication step in WF.

    5) Replace with Assignment step in WF instead of Syndication step

    6) Write s small Assignment in Data manager and assign in Assginment step.

    7) If you do like above,you don't need to worry about timings.When the WF passes the assignment ,immediately based on the settings in MDM Console and MDSS .ini File setting ,your records will be syndicated.

    If it solves your issues,pl award points.

    Thanks

    Ganesh Kotti

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 20, 2007 at 05:02 AM

    Hi Vadim,

    As for your problem if you notice in the syndicate stencil it has 3 properties name, description & port.

    If you use MDSS for automatic syndication you need to prepare the syndication map and store it with appropiate name under the proper remote system in syndicator.

    This map name you need to give in console->port->map name. ans set the processing type to automatic.

    If you follow these steps once the work flow comes to the syndicate step it will syndicate the record based on the timing you mentioned in the MDSS ini file(delay time) to the ready folder.

    As your next step is stop and you have given rollback in it.

    You need to keep you delay time in inin file as 0 so as soon as you pass the syndicate step your file is syndicate and then you reach the stop step.

    Hope it helped making the concepts clear.

    Regards

    Simona.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.