Skip to Content
author's profile photo Former Member
Former Member

Shortdump - 'MEMORY_NO_MORE_PAGING'

Hi

We are implementing ECC 5.0 in a phased approach accross regions, we have just implemented a large region and gone from about 100 concurrent users to 200 concurrent users, we are now getting shortdumps 'MEMORY_NO_MORE_PAGING', when I look at the shortdump it says 'you attempted to allocate a new SAP paging block, but no more blocks were available'. I am monitoring memory block usage through SM04 and we we do have large blocks being used occassionally, yesterday we got about 40 shortdumps in a 1 hour period, then no more for 2 hours, so I'm guessing a user used a particularly large chunk of page memory, is there any way to find paging usage historical per user? through ST03 or STAD? i've had a look and can't find it ?

Looking at parameter rdisp/PG_MAXFS it is set at 32768, which is 8K blocks, so about 262 MB, in ST02 this shows as paging area at 131072 in memory and 131072 on disk, if I was to quadruple this parameter to 131072, would that mean 524288 in memory and 524288 on disk ? or would the initial in memory still be 131072 with the remiander 917504 on disk? the parameter documentation makes it sound like all paging is on disk not memory?

The .DAT page file is in the /usr/sap/ we have plenty of free disk space there (15GB), is there any problems with making the page file so big? I can only do 1 downtime to implement this parameter, so I need to make sure its the correct setting as the project team are getting nervous !

We are runnings on WIndows 2003 64 Bit & MS SQL 2000.

Thanks for any help.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 04, 2007 at 05:10 PM

    Hi,

    There is no best value because that depends on the server.

    Apart from that general memory shortages in the system may be the reason.

    Your SAP paging file has reached its max. size.

    And also,

    This is a SAP profile parameter which can be changed. It is is split in 2 parts : - Memory part

    Size on hardware

    Both can be changed concerning by adapting the profile

    Search for rdisp/PG_SHM and rdisp/PG_MAXFS.

    Keep in mind, this a setting per server. If using more servers (APP's and DB) every setting should be changed per server.

    And also,

    Plz refer to SAP Note 619876 and 88416 also.

    Note: Points always encourage me to reply !!

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      'MEMORY_NO_MORE_PAGING' dump happens when there is no suffcient page memory available which can be overcome by increasing the parameter value for rdisp/PG_MAXFS. For this you need to have sufficient space in the /usr/sap/SID/ filesystem as the physical paging file is generated based on the parameter in the filesystem and in directory /usr/sap/<SID>/DVEBMGS<nr>/data/.

      Since you already have sufficient free space in filesystem you can increase the current value. For a ECC system with your user load, the current value 32768 is less and you can set that to 100000.

      Points if the info is useful.

      Regards,

      Sandy.

  • author's profile photo Former Member
    Former Member
    Posted on Feb 08, 2012 at 11:07 PM

    Hello,

    We too have received the 'MEMORY_NO_MORE_PAGING' errors. So I am working in a crash & burn to test out sizing of PAGFIL in /usr/sap/<SID>/<INSTANCE#>/data directory.

    I shutdown SAP, modified the instance profile - to increase the size of PAGFIL, run 'sappfpar check pf=<profile-name>, remove the pre-existing PAGFIL and restart SAP.

    At this point PAGFIL is created in the appropriate directory, however it is size 0.

    BTW - I've tried several different settings for rdisp/PG_MAXFS and every time now, the file is created with 0 length.

    How can I verify the size of the PAGFIL is set as I request in the instance profile?

    Thank you... Steve

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.