Skip to Content
avatar image
Former Member

ICM_HTTP_CONNECTION_FAILED

I established a H type RFC destination in SM59, which connect our R3 system to a XI system. The connection has following information:

target host: xidev

service number: 8000

path prefix: /sap/xi/engine?type=entry

Logon Procedure: SAP Standard

SSL: Inactive

I tested it in client 800, which is our business client, and I create the RFC in this client, it gave us a "ICM_HTTP_CONNECTION_FAILED", but if I test it in client 000, it give us a correct response.

While the client 800 gives "ICM_HTTP_CONNECTION_FAILED" prompt, I found following error in icm trace file:

[Thr 12112] *** WARNING => Connection request from (30/1496/0) to host: proxy, service: 8080 failed (NIEHOST_UNKNOWN)

RM-T30, U1496, 800 SHIPU, YiNing-PC, 15:55:05, M0, W0, SM59, 2/2 [icxxconn.c 2314]

Why there's a port 8080? our http port is 8000.

Anyone can help me?

Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 03, 2007 at 07:38 PM

    Hmm, you have an interesting problem.

    SM59 is cross client, so if it works in 000, it should work in 800.

    Unless it's due to authorization. It may be a long shot, try using ddic and run the test in 800.

    if not run debug and find where it's getting the 8080 port number.

    Good luck.

    regards,

    Laurence...

    disclaimer:

    The content of this message is my personal opinion only and, the statements I make here in no way represent my employer's position on the issue, nor am I authorized to speak on behalf of my employer on this matter.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 03, 2007 at 08:52 AM

    Hello Mao ,

    Did you check in SMICM -> Go To - > Services -> Active Services .

    You will find there the active services with the port details .

    Or else you can create the service with the required port 8080 or 8000 defination .

    Regards ,

    Santosh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 03, 2007 at 08:22 PM

    Hi,

    You are inputs are wrong. plese check

    target host : Better to specify IP Address (or Host name)

    Servive : 5<Instancenumber>00 and remaining things are ok.

    please change service number.

    Regards,

    Suraj

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear all, problem has been solved.

      03.07.2007 - 14:20:50 CET SAP

      Dear Mr. Mao,

      in the dev_icm trace i saw that connection test from C11 client 800

      connects to host proxy and not to host xidev:

      [Thr 5268] *** WARNING => Connection request from (29/1517/0) to host:

      proxy, service: 8080 failed (NIEHOST_UNKNOWN)

      RM-T29, U1517, 800 SAP_TEST, WDFD00102408A, 20:00:29, M0, W0, SM59, 3/2

      [icxxconn.c 2314]

      The reason was that in client 800 a proxy was defined

      in transaction sicf -> press F8 button -> menue: client:proxy settings.

      I unflagged the option 'proxy setting is active' and now it

      is working.