Skip to Content
0
Former Member
Jun 28, 2007 at 11:19 AM

Monitoring applet and JDK 1.6

12 Views

Hi everyone!

This might be slightly off-topic but I haven't been able to find a solution to the following problem:

On my computer I have installed JDK 1.4.2_14 in order to execute the XI webstart-apps. This works fine. Also, I am able to run the monitoring applet for end-2-end monitoring.

When I install a higher version of the JDK - in my case 1.6.0_01 - I am still able to get the webstart apps up and running using java control panel etc. However, I am unable to start the monitoring applet, since I get an exception thrown - I assume this is due to a version incompatibility. I have not found a possibility to configure the older java version in the java control panel, the registry, anything. The only possibility is de-installation of the newer jdk version.

My question now is: Is it possible to have two different versions of the jdk (e.g. 1.4 and 1.6) installed and <i>explicitly choose</i> which one is used to start applets? Or, more specifically, can I install jdk 1.6 and still use the monitoring applet of XI?

Regards,

Joerg