Skip to Content

how to ungrey object type in Equipment General Tab

Hi All,

Am facing one issue, I want to change the Object type in the Equipment General Tab, but the field is greyed out.

Kindly let me know how to change it to normal mode so that i can change the Object type in the Equipment.

Thanks?gards,

Thiruoathi.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Jul 14, 2017 at 04:28 AM

    Hi,

    In SPRO go to the PM&CS->Master data in plant maintenance & customer service->Technical object->Equipment->Define field selection for the equipment master record(execute)

    select field selection for equipment specific fields then select data for technical object and scroll down you will get object type field and select input radio button then save.

    Regards,

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 17, 2017 at 01:55 PM

    Hi Peter,

    Please find the screenshot for your reference.

    Thanks?gards,

    Thirupathi.

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 17, 2017 at 08:24 AM

    Hi All ,

    Still am facing the issue , even after making changes and testing also. Once we enter the value in the Object Type then system automatically getting grey out and it will not allow to changes.

    Please find the screenshot for reference. Kindly suggest.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Thirupathi,

      It should be done through some custom code.

      Normally Object Type field is an editable field when you create or save the Equipment. Since it gets grey out, check with your design documents or ask your abaper to debug it.

      Regards

      Terence

  • Jul 17, 2017 at 11:31 AM

    In the customisin image above, press the Influences button and send us the result.

    PeteA

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Peter,

      Thanks for all your time and also for all other people who has responded for this thread. We have found what exactly is the reason for it, there is an integration with other module and done some enhancements so system is not allowing to change it.

      Thanks all.