Skip to Content
0

Error in posting IDOC.. Field not member of segment

Jul 17, 2017 at 09:56 AM

33

avatar image

Hi All,

I have a scenario where we have extended CREMAS idoc and added a new custom segment (ZCREMAS_CIN000)to it last year and it was working fine when i was sending data from third party tool to ECC.

Recently we have added 1 new field (VEN_CLASS) to the same custom segment under the same version.

Now the current challenge which we are facing is when ever we send data through IDOC we are getting error " VEN_CLASS" not a member of ZCREMAS_CIN000.

VEN_CLASS is the new field which we added recently to the segment.

We have tested same in Sandbox server and QA server and its working fine.

But when we transported TR to Production server it gives above error. Is there any configuration which i'm missing?

This is SAP inbound scenario.

Please find below screenshots:

We31:

Kindly suggest!!!

Thanks In Advance

Regards, Ashish

idoc1.jpg (107.3 kB)
idoc2.jpg (64.3 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Jürgen L
Jul 17, 2017 at 11:10 AM
0

Is this screenshot from your development system or from the target system where the error occurred?

What is the error message number?

What happens after this error? Is your vendor master posted/updated? Or did you undo your changes and still using the old customizing to process the Idocs. I mean you posted this question already some weeks ago (I just alerted the moderator for cross posting), I can't really imagine that one could live with such error for several months not being able to create/update vendors.

Looking at your screenshot you previously defined the field names in your Z name space, this field is an exception to the previous approach, is there any reason for this exception?

Is there eventually some detailed information in the logs of the TR?

Share
10 |10000 characters needed characters left characters exceeded
Patrick Weber Jul 17, 2017 at 11:07 AM
0

It looks like there is a space in the field name mentioned in your error message. Could this be the reason?

Share
10 |10000 characters needed characters left characters exceeded