Skip to Content
0

SWPM - sapinst hung loading resource pool

Jul 15, 2017 at 07:44 AM

2.6k

avatar image
Former Member

SLES 12 - trying to load SWPM. I'm a noob to the basis world and I'm worried that I've got a network issue?? I've shut the firewall down. Getting the following when I execute sapinst

[==============================] \ extracting... done!

SAPinst build information:
--------------------------
Version: 749.0.27
Build: 1769809
Compile time: Jun 27 2017 - 05:16:26
Make type: optU
Codeline: 749_REL
Platform: linuxx86_64
Kernel build: 749, patch 300, changelist 1770269
SAP JRE build: SAP Java Server VM (build 8.1.030 25.51-b02, Apr 26 2017 16:01:22 - 81_REL - optU - linux amd64 - 6 - bas2:288514 (mixed mode))
SAP JCo build: 3.0.16
SL-UI version: 2.6.2
SAP UI5 version: 1.42.4
Exe directory: /tmp/sapinst_exe.6753.1500104168

INFO 2017-07-15 02:36:11.748 (root/sapinst) (SLPCommunicator) [/bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/guiengine/SLPMonitoringStatemachine.cpp:1371]

********************************************************************************
Access URL for GUI is
https://linux-m8ni.tristan-dom:4237/cZr3IFtNHiQYADzj/docs/index.html
Logon users: [root]
********************************************************************************

load resource pool /var/sap_download/swpm/resourcepool.xml

At this point it just hangs. Been looking through as much of the community as possible - but haven't found an answer. Anyone have any thoughts?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Bartosz Jarkowski Jul 23, 2017 at 07:53 PM
1

If you still encounter issue with ports blocked, try to run it "old fashioned" way, by executing sapinst with parameter:

SAPINST_SLP_MODE=false

It doesn't use the new look, therefore the ports used are also different.


Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

This worked - thanks so much for that!

0
Bartosz Jarkowski Jul 15, 2017 at 08:03 AM
1

Hi,

Did you try to use it and connect through browser? You can see in the message, there is a Access URL specified:

********************************************************************************
Access URL for GUI is
https://linux-m8ni.tristan-dom:4237/cZr3IFtNHiQYADzj/docs/index.html
Logon users: [root]
********************************************************************************

Please read the following blog, it will give you overview about the new SWPM :)

https://blogs.sap.com/2017/05/23/make-swpm-1.0-sp20-work-for-you/

And finally, if you prefer the old-style SWPM you can just add SAPINST_SLP_MODE=false parameter to your sapinst.

Best regards

Bartosz

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks for the hint, Bartosz. I tried the URL - nothing came up.

However that left enough time for the sapinst process to complete. I guess I needed more patience there. Unfortunately, it ended in error.

[Thr 140587448080128] =================================================
[Thr 140587448080128] = SSL Initialization platform tag=(linuxx86_64_gcc43)
[Thr 140587448080128] = (749_STACK,Jun 27 2017,mt,ascii-uc,SAP_UC/size_t/void* = 16/64/64)
[Thr 140587448080128] = resulting Filename = "/tmp/sapinst_exe.6753.1500104168/libsapcrypto.so"
[Thr 140587448080128] = disabled FIPS 140-2 crypto kernel
[Thr 140587448080128] = found CommonCryptoLib 8.5.13 (May 17 2017) [AES-NI,CLMUL,SSE3,SSSE3]
[Thr 140587448080128] = current UserID: "root", env-var USER=<not set>
[Thr 140587448080128] = using SECUDIR=/root/.sapinst/./sec

[Thr 140587448080128] Sat Jul 15 02:36:11:728 2017
[Thr 140587448080128] = [ctc] ssl/ciphersuites=HIGH:MEDIUM:+e3DES:!aNULL
[Thr 140587448080128] = [ctc] ssl/client_ciphersuites=HIGH:MEDIUM:+e3DES:!aNULL
[Thr 140587448080128] = Success -- SapCryptoLib SSL ready!
[Thr 140587448080128] =================================================
[Thr 140587448080128]
[Thr 140587448080128] *** ERROR => NiIBindSocket: SiBind failed for hdl 25/sock 10
(SI_EPORT_INUSE/98; I4; ST; 0.0.0.0:4237) [nixxi.cpp 3883]
[Thr 140587448080128] *** ERROR => IcmBindService: NiBuf2Listen failed for host linux-m8ni.tristan-dom:4237 (rc=-4): NIESERV_USED [icxxserv.c 3933]
[Thr 140587448080128] *** WARNING => IcmAddService: Could not start service (rc=-22) PORT=4237,PROT=HTTPS,TIMEOUT=60,PROCTIMEOUT=60,VCLIENT=1 [icxxserv.c 1375]

So the problem is a conflict on port 4237. When I checked on that port, looks like it was taken by sapwebdisp

0
Former Member

tcp 0 0 0.0.0.0:4237 0.0.0.0:* LISTEN 20654/sapwebdisp

0
Former Member

Hello Tim,
IcmBindService: NiBuf2Listen failed for host linux-m8ni.tristan-dom:4237 (rc=-4): NIESERV_USED [icxxserv.c 3933]

Indicates port 4237 is occupied.Try using some other free/available port.

If the issue still persists kindly attach the sapinst_dev.log here.

Cheers!

Regards,
Manjunath Hanmantgad

0
Former Member

Been a long week of travel and I wasn't able to get back to this. Thank you for the suggestion, Manjunath. I executed swpm specifing the port with the following command

./sapinst SAPINST_DIALOG_PORT=49139 GUISERVER_DIALOG_PORT=49130

It hangs for over an hour if I let it. When I kill it - I think there is still some sort of SSL issue?? Trying to figure out this on my own, but this really isn't my background.

swpm-error-log.txt

swpm-error-log.txt (17.2 kB)
0