Skip to Content
avatar image
Former Member

the BPM stops, with a "green flag " in the sxmb_moni enrty

i have a file to file with a BPM,

the BPM contains:

1. a loop which runs five times which contains a receive step with [start transaction] and a using and activating correlation value.

2. a container step that appneds the messages picked one by one through each iteration of loop into a multiline container.

3. a send step.

the purpose is to collect 5 files with a particular correlation value and merge them and send them,

the problem is, as soon as the file is picked and the message is received at the receive step, the BPM stops, with a "green flag " in the sxmb_moni enrty,

i cant make out anything from the PE in the moni entry....

is it some problem with the correlation......help me out...

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jun 27, 2007 at 04:22 AM

    Sudeep,

    -- Are u not using any transfomations step?

    -- If the correlation is active then u will see the clock symbol.

    -- Is it possible for u too see the graphical workflow log.

    Best regards,

    raj.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      yes Raj,

      i have a transformation step ...that transforms the content of the multiline container into a normal container before sending.............

      this is the problem, i can never see the wait symbol, and

      its sometimes strange, some times the process ends with "red flag" on the outbound side (right hand side of the moni entry)...

      i can see the graphical............

      i forgot to mention...all the steps are in a block....

      so in the graphical wf log, i can see an error at the entry of the block, except that there is no error.....