Skip to Content
0

SAP Lumira 1.31 Patch 7 Installation Error

Jul 14, 2017 at 01:06 PM

145

avatar image

Hi All,

We are trying to install SAP Lumira 1.31 Patch 7 on machine having Windows 8 as OS but getting below error.

When we tried to install SAP Lumira 1.31 version on same machine it is getting insatlled without any error.

eclipse.buildId=unknown
java.version=1.7.0_85
java.vendor=SAP AG
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments:  -application com.sap.hilo.backend.helpers.application step2
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -application com.sap.hilo.backend.helpers.application step2
!ENTRY org.eclipse.equinox.ds 4 0 2017-07-14 15:18:06.710
!MESSAGE Could not bind a reference of component com.sap.ip.bi.base.application.DeclaredServiceActivator. The reference is: Reference[name = IActivatorBase, interface = com.sap.ip.bi.base.bundle.IActivatorBase, policy = dynamic, cardinality = 0..n, target = null, bind = addRICActivator, unbind = removeRICActivator]
!ENTRY org.eclipse.equinox.ds 4 0 2017-07-14 15:18:06.710
!MESSAGE Could not bind a reference of component com.sap.ip.bi.base.application.DeclaredServiceActivator. The reference is: Reference[name = IActivatorBase, interface = com.sap.ip.bi.base.bundle.IActivatorBase, policy = dynamic, cardinality = 0..n, target = null, bind = addRICActivator, unbind = removeRICActivator]
!ENTRY org.eclipse.osgi 4 0 2017-07-14 15:18:08.491
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: org.eclipse.core.runtime.CoreException: Plug-in "com.sap.hilo.engine.hanalite" was unable to instantiate class "com.sap.hilo.engine.hanalite.HanaLiteLocalBackendStarter".
at com.sap.hilo.orchestration.factory.internal.osgi.eclipse.EclipseExtensionManager.createContributionInstanceFromName(EclipseExtensionManager.java:52)
at com.sap.hilo.orchestration.factory.ExtensionFactory.getContributionInstanceFromName(ExtensionFactory.java:53)
at com.sap.hilo.backend.helpers.BackendStarterFactory.createBackendProvider(BackendStarterFactory.java:26)
at com.sap.hilo.backend.helpers.BackendStarter.getInstance(BackendStarter.java:573)
at com.sap.hilo.backend.helpers.BackendStarterApplication.start(BackendStarterApplication.java:39)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
Caused by: org.eclipse.core.runtime.CoreException: Plug-in "com.sap.hilo.engine.hanalite" was unable to instantiate class "com.sap.hilo.engine.hanalite.HanaLiteLocalBackendStarter".
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:194)
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:188)
at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905)
at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:55)
at com.sap.hilo.orchestration.factory.internal.osgi.eclipse.EclipseExtensionManager.createContributionInstanceFromName(EclipseExtensionManager.java:47)
... 16 more
Caused by: java.lang.UnsatisfiedLinkError: C:\Program Files\SAP Lumira\Desktop\configuration\org.eclipse.osgi\bundles\143\1\.cp\hl-lib\vcruntime140.dll: Can't find dependent libraries
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:2069)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1994)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1968)
at java.lang.Runtime.loadLibrary0(Runtime.java:849)
at java.lang.System.loadLibrary(System.java:1095)
at com.sap.hilo.engine.hanalite.HanaLiteLocalBackendStarter.<init>(HanaLiteLocalBackendStarter.java:58)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
at java.lang.Class.newInstance(Class.java:392)
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:184)
... 20 more
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Ludek Uher
Jul 18, 2017 at 09:49 PM
0

Is that the error, or output from the install log?

By "1.31 version", you mean 1.31.0?

Are you doing an upgrade or a fresh install?

Try to right click on the install exe and select "Run as Administrator"

- Ludek Senior Support Engineer AGS Product Support, Global Support Center Canada

SAP is now offering chat support. For more details please see KBA 2213344 - How to start a chat with SAP Support[video]

Follow me on Twitter: https://twitter.com/crnanalysistips

Share
10 |10000 characters needed characters left characters exceeded