Skip to Content
avatar image
Former Member

ICM : 400 error Session timed out

Greetings all,

we have a BSP page, when we try to access through the portal most of the time it works fine , but occasionally we encounter this error 400 Session timed out.

other details of the error ,

error: (-11)

component ICM

module:icxxthr_mt.c

..

...

...

This happens suddenly while we are active on the system.

after checking into the system with SMICM transaction I found out that the number of current <i><b>created worker threads</b></i> approaching the maximum limits, but not exceeding it.

when i checked the same transaction when the page was successfully excuted without that error i found out the number of current <i><b>created worker threads</b></i> is fairly away from the maximum limits.

could it be that this is the problem.

the problem here that i don't have the right to just change the maximum and see for myself, so i have to look this up and came up with the solution then go to the right guy and just ask him to do it.

Thanks & Regards

Mohammed

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jun 26, 2007 at 06:51 AM

    Hi,

    'What is parameter icm/conn_timeout' value in your system ? The system's Internet Connection Manager(ICM) is configured for 5000ms (Default value). The processing time for the root node exceeds this specified connection time of 50 secs. This results in time out error.

    Please change the value to 50000.

    Please refer the note 774439 - Connection time out for the BSP Application & 737625 - Parameter recommendations for the ICM

    Cheers,

    Shyam

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 02, 2008 at 08:26 AM

    Hi Mohammed,

    We are also facing the same problem in EP 7.0. can you please tell me the solution.

    Regards,

    Bala.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Bala,

      I recommend to read SAP note 705013, I think adjusting the kernel parameters

      rdisp/gui_auto_logout and

      rdisp/plugin_auto_logout

      will help.

      Regards,

      Kanthi