Skip to Content
avatar image
Former Member

Error when adding wizard pages

Hi,

After creating a model by importing an adaptive web service model, I tried to apply template for a view, and I got an internal error with the following stack trace. Any suggestions for how to fix this problem?

Many thanks in advance.

Van

==============

java.lang.NullPointerException

at com.sap.ide.webdynpro.template.wizards.formview.ContextSelectionPageListener.addAttributes(ContextSelectionPageListener.java:455)

at com.sap.ide.webdynpro.template.wizards.formview.ContextSelectionPageListener.getContextAttributes(ContextSelectionPageListener.java:430)

at com.sap.ide.webdynpro.template.wizards.formview.ContextSelectionPageListener.getContextAttributes(ContextSelectionPageListener.java:429)

at com.sap.ide.webdynpro.template.wizards.formview.ContextSelectionPageListener.initializeContextAttributes(ContextSelectionPageListener.java:409)

at com.sap.ide.webdynpro.template.wizards.formview.ContextSelectionPageListener.<init>(ContextSelectionPageListener.java:69)

at com.sap.ide.webdynpro.template.wizards.formview.FormViewWizard.addPages(FormViewWizard.java:80)

at com.sap.ide.tools.core.template.wizard.apply.ApplyTemplateWizard.addPages(ApplyTemplateWizard.java:84)

at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:468)

at org.eclipse.jface.window.Window.create(Window.java:302)

at org.eclipse.jface.window.Window.open(Window.java:552)

at com.sap.ide.tools.core.template.startup.ApplyTemplateAction.run(ApplyTemplateAction.java:35)

at com.sap.ide.tools.core.template.invoke.TemplateInvoker.startApplyTemplateAction(TemplateInvoker.java:86)

at com.sap.ide.tools.core.template.invoke.TemplateInvoker.startApplyTemplateWizard(TemplateInvoker.java:42)

at com.sap.ide.webdynpro.tsmodel.application.actions.ApplyTemplateAction.run(ApplyTemplateAction.java:49)

at com.sap.ide.webdynpro.tsmodel.application.actions.DevelopmentObjectAction.runInternal(DevelopmentObjectAction.java:63)

at com.sap.ide.webdynpro.tsmodel.application.actions.ApplyTemplateAction.run(ApplyTemplateAction.java:39)

at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:251)

at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:456)

at org.eclipse.jface.action.ActionContributionItem.handleWidgetEvent(ActionContributionItem.java:403)

at org.eclipse.jface.action.ActionContributionItem.access$0(ActionContributionItem.java:397)

at org.eclipse.jface.action.ActionContributionItem$ActionListener.handleEvent(ActionContributionItem.java:72)

at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:81)

at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:840)

at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:2022)

at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:1729)

at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1402)

at org.eclipse.ui.internal.Workbench.run(Workbench.java:1385)

at com.tssap.util.startup.WBLauncher.run(WBLauncher.java:79)

at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:858)

at org.eclipse.core.boot.BootLoader.run(BootLoader.java:461)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at com.sap.ide.eclipse.startup.Main.basicRun(Main.java:291)

at com.sap.ide.eclipse.startup.Main.run(Main.java:789)

at com.sap.ide.eclipse.startup.Main.main(Main.java:607)

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jun 25, 2007 at 09:25 AM

    Hi,

    Can you explain us where exactly the error is ?

    regards

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Joseph BERTHE

      Hi Berthe Joseph,

      I've tried to remove the current model, then re-importing the model as Web Service Model (deprecated) instead of importing as Adaptive Web Service Model, the error goes away. And now I can apply template to the UIElement, and all the fields are now editable without having to set the cardinality to 1..n.

      I'm not quite sure the differences between importing Adaptive Web Service Model and importing Web Service Model have caused the error.

      Thanks for your help.

      Regards,

      Van

  • avatar image
    Former Member
    Oct 12, 2007 at 10:32 AM

    Hello,

    The issue has been identified and fixed in the upcoming releases.

    It would most probably be part of the future release (SP14) around Dec - Jan.

    Kind Regards,

    Nitin

    Add comment
    10|10000 characters needed characters exceeded