Skip to Content
avatar image
Former Member

Problem to use feature 'Reimport Model' from NWDS 7.5

Hi, Experts!

We upgrade our SAP Portal from NW 7.02 to NW 7.5. According to SAP note 2250903 we have to use Java 8.

So, we downloaded NWDS 7.5 SP 08 and imported project developed into Java 1.4 (NW 7.02). When we tried opening this project a message said that we have to migrated it.

On this message, we clicked on Quick Fix, in context menu.

After we migrated this project, everything was fine. So we tried to Reimport Models.

At this moment nothing happens. We note that a java log will generated:

!ENTRY org.eclipse.ui 4 0 2017-07-13 10:35:35.115
!MESSAGE Unhandled event loop exception
                at org.eclipse.jface.wizard.WizardDialog.showStartingPage(
                at org.eclipse.jface.wizard.WizardDialog.createContents(
                at org.eclipse.jface.window.Window.create(
                at org.eclipse.jface.dialogs.Dialog.create(
                at org.eclipse.ui.actions.BaseSelectionListenerAction.runWithEvent(
                at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(
                at org.eclipse.jface.action.ActionContributionItem.lambda$4(
                at org.eclipse.swt.widgets.EventTable.sendEvent(
                at org.eclipse.swt.widgets.Display.sendEvent(
                at org.eclipse.swt.widgets.Widget.sendEvent(
                at org.eclipse.swt.widgets.Display.runDeferredEvents(
                at org.eclipse.swt.widgets.Display.readAndDispatch(
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(
                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
                at org.eclipse.ui.internal.Workbench$
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(
                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
                at org.eclipse.ui.internal.ide.application.IDEApplication.start(
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(
                at java.lang.reflect.Method.invoke(
                at org.eclipse.equinox.launcher.Main.invokeFramework(
                at org.eclipse.equinox.launcher.Main.basicRun(
                at org.eclipse.equinox.launcher.Main.main(

What do we need to do to use this feature? Is there something wrong with this procedure?

Thanks in advanced.


migration.png (14.6 kB)
quick-fix.png (31.8 kB)
reimport-model.png (54.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jul 17, 2017 at 09:20 AM

    Dear Sergio,

    I would suggest that migrate your model to ARFC2. I think it can help. Additionally, make sure that you have a backup project.

    Best regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Szabolcs.

      Thanks for your answer.

      My doubt is about time. We have already estimated time for this project without consider ARFC2 migration.

      How long do you think it is going to take migration for each model? The NW upgrade is from 7.02 to 7.5, so RFC ABAP functions interface have built with obsolete statements. Do you think that it might be a problem?

      And this feature in NWDS should not be working? Why does this error happen?

      Best Regards.


  • Jul 19, 2017 at 05:49 AM

    Hi Sergio,

    I have recently done the webdynpro java migration myself and the model migration should not take much time. You should be able to complete the migration within a day.

    Regarding the code change, you just need to do one minor change. In ARFC2, the model objects are instantiated with reference to their model.

    <ModelClass> modelObject = new <ModelClass>();

    <ARFC2Model> model = new <ARFC2Model>();
    <ModelClass> modelObject = new <ModelClass>(model);

    Just identify these and change accordingly. You should be fine.



    Add comment
    10|10000 characters needed characters exceeded

    • Hi Team,

      Getting this error while trying to migrate to ARFC2Model even after maintaining the Destination under preferences.

      I am using 7.5 SP 6 NWDS and using JDK 1.8.0_131 64 bit.

      Please help me to resolve this error. I am not able to proceed because of this error.

      Thanks & Regards,

      Kishor Gopinathan

      erd.png (17.7 kB)
  • Nov 20, 2018 at 09:38 AM


    I am getting the error when trying to re-import a model.

    I have confirmed with Basis that my R/3 Configuration is correct.

    Hoping someone here can advise.



    reimport-error.jpg (14.4 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Dec 04, 2018 at 10:25 AM


    ARFC1 model is not supported in 7.5 NWDS. Please check note 2121560 - ARFC1 is deprecated from NW 7.11.
    There is no option to create a new ARFC1 model in NWDS 7.31 or higher. Hence even ARFC1 model reimport will not work.

    It is possible to execute ARFC1 model on 7.5 server. But if any changes are needed which requires model reimport, in that case the only option is to migrate to ARFC2.


    Add comment
    10|10000 characters needed characters exceeded