Skip to Content
avatar image
Former Member

no gui connected --- how to change the ports

Hi

I would like to know how to change the following??

You just change the port no to a different one.By default sap always uses 21212 port for installation.But you can change this by following the below steps:

./sapinst GUISERVER_DIALOG_PORT=21201 SAPINST_DIALOG_PORT=21213

Run sapinst with the above parameter.

Any issues in applying the above steps.......do let me know.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Jun 19, 2007 at 01:05 PM

    this is failing half way threw the install

    I have installed all the components of the Netweaver 2004s and it was at the step of installing software units.

    My variable are like this

    JAVA_HOME = j2sdk1.4.2_13

    I am not too sure what to do at this point.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 19, 2007 at 12:51 PM

    Hi

    Did you set the display variable ? Also close all the sapinst and try again .Eexecute ps and make sure no sapinst processes are running before start sapinst again. If you want to use another port , procedure is mentioned in the installation dopcument ..

    During the installation, the default ports 21200 and 21212 are used for communication between

    SAPinst, GUI server, and SAPinst GUI. SAPinst uses port 21200 to communicate with the GUI

    server. The GUI server uses port 21212 to communicate with SAPinst GUI. You get an error

    message if one of these ports is already in use by another service.

    In this case, you must execute sapinst using the following parameters:

    SAPINST_DIALOG_PORT=<free_port_number_sapinst_gui_to_gui_server>

    GUISERVER_DIALOG_PORT=<free_port_number_gui_server_to_sapinst_gui>.

    To get a list of all available SAPinst properties, start SAPinst as described above with the option

    -p:

    ./sapinst -p.

    Thanks

    Prince Jose

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 19, 2007 at 05:18 PM

    windows 2003 server

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2009 at 01:36 PM

    found the port

    problem solved

    Add comment
    10|10000 characters needed characters exceeded