Skip to Content
1

URGENT - Fiori Fact Sheets - One Web Dispatcher and Two Backend Servers

Jul 13, 2017 at 12:13 AM

102

avatar image

Hi.

Please, does anyone know any solution to the problem below?

Have the follow system architecture:

- One Fiori Frontend server with transactional and fact sheet applications for ECC and only transactional applications for SRM
- Two Backend servers, ECC and SRM
- One Web Dispatcher

I activated Fact Sheets for some applications that are in the ECC (backend) and configurated the Web Dispatcher for Enterprise Search, pointing to ECC. This is working fine. When i do a search, the content from backend (ECC) is returned to frontend correctly.

There is no fact sheet applications for SRM and there is no configuration on Web Dispatcher pointing to this system. Transactional applications for SRM uses SAP Gateway services. Works fine.

If my system user has access on both back end systems, everything works fine but, if my system user has access only in the SRM there is a trouble.

Accessing Fiori Lpd with a user who only has access in the SRM system, when clicking on username or search button, Web Dispatcher tries to call enterprise search in the ECC. A login prompt ask for credentials. This happens because the user has not access in the ECC and SSO doesn't work.

I created the system user in the ECC and the problem stopped. This can not happen because we will not have a license for this user in this environment.

Even if the user only needs to access the SRM, should have a user in the ECC?

Is there a way to block the call to those who do not have access to the ECC system?

Thanks for your time.

Best Regards,

Guilherme

sem-titulo.png (95.6 kB)
capture.png (106.5 kB)
sem-titulo.png (24.2 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Jul 16, 2017 at 07:17 PM
1

Hi Guilherme,

It seems the redirect is happening that when the user is not in ecc but still wdp is checking in backend ecc and giving 403 error.
Check if the error is coming if the client protocol is http ?

Also check if "Do not switch" service is set in SICF to allow http to login? and ensure you have this url in HTTPURLOC table maintained.

Regards,
Manjunath Hanmantgad

Share
10 |10000 characters needed characters left characters exceeded
Guilherme Lahr Aug 18, 2017 at 01:09 AM
0

Hi Manjunath.

Thank you very much for you attention.

I opened an OSS ticket to SAP. On this week received the answer that my scenario is not supported.

The recommended solution was create usernames on both systems, ECC and SRM, or use a different hostname for each one.

Did not solve my problem but at least i have an official answer.

Thanks and best regards.

Share
10 |10000 characters needed characters left characters exceeded