Skip to Content
author's profile photo Former Member
Former Member

BPM problem in PI (XI 7.0)

Hi guys!

I have a scenario, where I use BPM. The underlying system is PI 7.0 (NW 2004s). I send Idoc from r/3, send it into bpm, this should make a sync call to web service and the ws response is mapped to ather idoc and sent again into r/3.

I created all the necessary objects in repository and directory and have a problem - when I send the Idoc, it is received by XI, but not processed... the status of the message is Scheduled. In the receiver interface and receiver there are no values in spite i have configured receiver and interface determination... 😔

This is already the 2nd PI, where I have this problem. In the first one I was able to ommit the BPM, but here I am not. Does someone have the same experience? Problems with BPM in PI7.0?

I was looking also on the workbench component monitor - BPM - tha status is yellow triangle.. Sub-parts with NONgreen light are:

Maintain prefix numbers

Configure RFC destination

Schedule background job for missed deadlines

Schedule background job for work items with errors

Schedule background job for event queue

Schedule background job for clearing report

Schedule background job for deadline monitoring

How to fix these problems? is there any guide? Is it a task for basis person or consultant?

Thanx a lot for answer! Points are guaranteed 😊

Olian

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Jun 18, 2007 at 01:35 PM

    Olian,

    Could you please describe the steps u have done in BPM.

    Best regards,

    raj.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 18, 2007 at 01:34 PM

    Hi,

    did you register the queues in SXMB_ADM - regster queue ?

    Regards,

    michal

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 08:47 AM

    Hi All -

    Did you find a solution to the problem stated above

    "it is received by XI, but not processed in BPM... the status of the message is Scheduled on outbound side"

    Many Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 09:31 AM

    hi Olian,

    as you are saying like your message came upto XI , but not proccessed so may be its a problem of queue so to <b> TCode::SMQ1 and SMQ2 and clear this QUEUE.</b>

    hope this will solve this issue.

    your one prob is <b>Configure RFC destination</b>

    <b>so check in R/3 sys Tcode : SM59 for RFC Destination</b>

    can you make remote login and connection test , if not so make technical Setting Properly.

    hope this will help

    regards

    HONEY

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.