Skip to Content

SMP 3.0 - iOS 11-USER Registration Error

Jul 13, 2017 at 03:36 PM


avatar image

Dear All,

We are testing the SMP 3.0 Native iOS App with iOS11 beta3.

If a custom Native iOS App developed with MBO try to REGISTER the user in SMP3.0 appear an error in the Object API "registerApplication" and the registration failed.

Else if we try to use an App already register in SMP before the upgrade of iPad to iOS11 everything work correctly, the user can access and synch. the data correctly. Infact in this case the App doesn't execute the API "registerApplication".

We have execute a lot of test to identify the problem reason and seems that not depends from relay server because we have the same error if the App try to connect directly to SMP.

With iOS 10 everything work correctly.

Version of SMP Server and SDK used to deploy the MBO:

SMP 3.0.12


Version of iOS and XCODE used

iOS11 beta 3 vers.: 11.0 (15A5318g)

XCODE 9.0 beta 3 (9M174d)

Below you can see the ERROR LOG that appear in XCODE console during the App registration


2017-07-13 14:28:27.206698+0200 AT01Sales1[368:51312] ================================================

2017-07-13 14:28:27.317958+0200 AT01Sales1[368:51312] [ERROR] [SUPApplication.m:1480] error @ registerApplication MessagingClientException {

ErrorCode = 516;

ErrorMessage = "";


2017-07-13 14:28:27.318040+0200 AT01Sales1[368:51312] =================================================

2017-07-13 14:28:27.318062+0200 AT01Sales1[368:51312] onRegistrationStatusChanged: status = 201, code = 516, message = SUPApplicationError_REGISTRATION_Resetting Communications

2017-07-13 14:28:27.318084+0200 AT01Sales1[368:51312] =================================================

2017-07-13 14:28:27.360632+0200 AT01Sales1[368:51274] SUPApplication connectionStatus -----> 105

2017-07-13 14:28:27.415739+0200 AT01Sales1[368:51274] API error: (null) returned 0 width, assuming UIViewNoIntrinsicMetric

2017-07-13 14:28:27.415822+0200 AT01Sales1[368:51274] API error: (null) returned 0 width, assuming UIViewNoIntrinsicMetric


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Jitendra Kansal
Jul 17, 2017 at 09:03 AM

Hello Robert,

There is no iOS 11 support yet in SMP 3.0, it will be available only after official release of this OS. Please check SAP note



10 |10000 characters needed characters left characters exceeded
Romano Soligo Jul 19, 2017 at 01:08 PM

Hi Jitendra,

thanks for your answer, the SAP note that you have indicated is the problem that I advised to SAP with OSS but there is a difference between my error and the SAP Note: I'm using SDK2.3 SP9 LP1 to deploy the MBO and generate the iOS code and also I'm using the libraries contained in SDK2.3. In SAP Note is indicated the SDK3.x

My question is: I have tried to install SDK3.0 but I don't understand how to see the MBO SDK (like in SDK2.3) in order to change something in MBO, deploy the model to SMP3.0 and generated the iOS code. There are some tutorial in order to understand how to do this in SDK3.0 ? In this way when SAP will release the patch for iOS11 I'm ready to use the SDK3.0.

Many thanks.



10 |10000 characters needed characters left characters exceeded
Ross Lewis Jan 29 at 06:13 PM

Hi Roberto, we are experiencing this very same issue. Have you found a solution?

Devices that are registered can upgrade to ios11 and seem unaffected. However, when a new ios11 device tries to register, it receives this same error 516. We have bypassed the relay server also and still receive the same error. ios10 devices work and register normally.

ERROR=fail in SUPApplication--registerApplication: SUPApplicationRuntimeException:error @ registerApplication 516 SUPApplicationError_REGISTRATION_Resetting Communications

10 |10000 characters needed characters left characters exceeded