Skip to Content
avatar image
Former Member

ABAP Proxy configuration

I have 2 clients on my XI server.

Client 350 is the Integration engine. Client 450 is another client on same server from which I want to send data to XI.

I am referring to the foll. webblog for config

/people/vijaya.kumari2/blog/2006/01/26/how-do-you-activate-abap-proxies

In step 1. Create HTTP connection in the business system, after I create the RFC dest to client 350 I get the message

HEADER NAME HEADER VALUE

response_line HTTP/1.0 500 Empty HTTP request received

server_protocol HTTP/1.0

status_code 500

status_reason Empty HTTP request received

ontent-type text/xml

ontent-length 814

ontent-id <soap-6959E2DC94E63D4BBD8977E7250CB115@sa

oapaction 'http://sap.com/xi/XI/Message/30'

erver SAP Web Application Server (1.0;640)

HTTP BODY

SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

OAP:Header>#</SOAP:Header>#<SOAP:Body>#<SOAP:Fault xmlns:SOAP="http:/

SOAP:Clienthemas.xmlsoap.org/soap/envelope/"> SOAP:Client><

ltstring>Empty HTTP request received</faultstring><faultactor>http://

.com/xi/XI/Message/30</faultactor><detail><SAP:Error xmlns:SAP="http:

ap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/

elope/" SOAP:mustUnderstand="1"><SAP:Category>XIProtocol</SAP:Categor

SAP:Code area="MESSAGE">EMPTY_HTTP_REQUEST_RECEIVED</SAP:Code><SAP:P1

SAP:P2/><SAP:P3/><SAP:P4/><SAP:AdditionalText/><SAP:ApplicationFaultM

age namespace=""/><SAP:Stack>Empty HTTP query received. No message pr

ssing possible##</SAP:Stack></SAP:Error></detail></SOAP:Fault>#</SOAP

dy>#</SOAP:Envelope>#

Time (ms) 192

Also I need to know whether all the steps in this blog are to be performed on the client 450 ( in my case )

I have done all the steps on client 450. I am still getting the message "No connection to Integration Builder (only local data available)"

Thanks and Regards,

Ashwin

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 15, 2007 at 11:29 AM

    Hi

    Go to this URL

    http://<host>:<port>/exchangeProfile/

    and chk whether these parameters are present in Connections foer the XI server to which u wish to connect from SAP System

    com.sap.aii.connect.repository.name

    com.sap.aii.connect.repository.httpport

    com.sap.aii.connect.repository.contextRoot

    com.sap.aii.connect.integrationbuilder.startpage.url

    If these parameters are not present then add them.

    regards

    krishna

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Udo Martens

      Dear Udo, Krishna

      The User XIAPPLUSER was maintained as a dialog user in SU01.

      We changed it to service user. Now the transaction SPROXY is working OK.

      Thanks for all your help and patience.

      Regards,

      Ashwin

  • Jun 15, 2007 at 11:27 AM

    Hi Ashwin,

    your http connection is working 😊

    Go to SPROXY at 450 and double click on the error msg at the bottom, you ll get a good help. The connection to Integration Builder has to be customized at Exchange Profile.

    Regards,

    Udo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 15, 2007 at 11:27 AM

    Hi

    check the following OSS Note

    SAP Note 689847 XI 3.0:- No connection to the Integration Builder

    regards

    krishna

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 15, 2007 at 11:28 AM

    Hi

    Go to this URL

    http://<host>:<port>/exchangeProfile/

    and chk whether these parameters are present in Connections foer the XI server to which u wish to connect from SAP System

    com.sap.aii.connect.repository.name

    com.sap.aii.connect.repository.httpport

    com.sap.aii.connect.repository.contextRoot

    com.sap.aii.connect.integrationbuilder.startpage.url

    If these parameters are not present then add them.

    regards

    krishna

    Add comment
    10|10000 characters needed characters exceeded