Skip to Content
0

unable to start saprouter on aix

Jul 13, 2017 at 11:33 AM

229

avatar image
Former Member

saprouter -r

trcfile dev_rout no logging active

WARNING: wildcard character used in route target

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Isaias Freitas
Jul 14, 2017 at 08:18 PM
0

Hello Vikas,

It looks like your saprouter has started...

What happened after you executed that command?

Best regards,

Isaías

Show 10 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Isaías,

Not sure because in system SAPOSS RFC is not working

LogonConnection Error Error DetailsError when opening an RFC connection Error DetailsERROR: partner '10.48.xxx.xx:3299' not reached Error DetailsLOCATION: SAP-Server sap1apqe_APQ_02 on host sap1apqe (wp 11) Error DetailsDETAIL: NiPConnect2: 10.48.xxx.xx:3299 Error DetailsCALL: connect Error DetailsCOMPONENT: NI (network interface) Error DetailsCOUNTER: 7 Error DetailsERROR NUMBER: 79 Error DetailsERROR TEXT: A remote host refused an attempted connect operation. Error DetailsMODULE: nixxi.cpp Error DetailsLINE: 3286 Error DetailsRETURN CODE: -10 Error DetailsSUBRC: 0 Error DetailsRELEASE: 720 Error DetailsTIME: Sun Jul 16 14:52:09 2017 Error DetailsVERSION: 40

Best regards,

vikas

0

Hello Vikas,

I believe that the IP you have masked (10.48.xxx.xx) would be the IP address of the saprouter server, correct?

Can you please share the exact command used to start the saprouter?

Was it only "saprouter -r"?

Was it started manually or through a script?

Is the saprouter process still running? You can check this with the command "ps -ef | grep saprouter", executed at the saprouter server.

Best regards,

Isaías

0
Former Member
Isaias Freitas

Hi Isaías,

Yes it is(10.48.xxx.xx) saprouter server of our local sap.

saprouter -r trcfile dev_rout no logging active routtab cannot open './saprouttab': EXIT PROGRAM !!! (running without saproutab is no longer supported for security reasons) Could not open permission table

permission: drwxrwxr-x 2 apdadm sapsys 4096 Jul 13 15:22 saprouter

I think gave full permission to table chmod 775 saprouter

but still same error..

ps -ef | grep saprouter
apdadm 16908536 16318492 2 07:11:11 pts/0 0:00 grep saprouter

Thank you

Best regards,

vikas

0

Hello Vikas,

From your previous reply:

cannot open './saprouttab': EXIT PROGRAM !!! (running without saproutab is no longer supported for security reasons) Could not open permission table

You have to create a file named "saprouttab" at the same folder as the saprouter.

If you want to use a different file name/location, you need to specify the path to the file with the "-R <path to file>" argument.

For information about the saprouttab file, read the PDF file attached to the SAP Note 30289.

Best regards,

Isaías

0
Former Member
Isaias Freitas
capture123.png (28.0 kB)
0

From which folder was the saprouter started?

Were you at "/usr/sap/saprouter"?

Try starting the saprouter with this command:

saprouter -r -R /usr/sap/saprouter/saprouttab

You should be logged on as "apdadm" when executing that command.

0
Former Member

Hi,

What is the error you are getting while testing connection for SAPOSS RFC in SM59?

Can you attach the screen shot here so that we can take a look.

Regards,

Manjunath Hanmantgad

0
Former Member
Former Member
capture.png (38.6 kB)
0
Former Member

Hi Vikas,

check if you are able to do successful niping test as:

niping -v -H 10.48.X.X - S 3299

this should be resolving correctly.

You can attach the output here.

Regards,
Manjunath Hanmantgad

0
Former Member
Former Member
capture12.png (26.8 kB)
0
Reagan Benjamin
Jul 19, 2017 at 01:05 PM
0

Based on what you have supplied initially there is no error. The saprouter file you have listed doesn't look real to me. Did you download the saprouter file from the SAP Market Place? What is the exact command you used to start the saprouter?

Show 12 Share
10 |10000 characters needed characters left characters exceeded
Former Member


Maybe same router is expired so
trying to renew SAProuter Certificate

uising this link - http://waddaya.com/blog/wp-content/uploads/2016/11/SapRouter-Install-in-Linux.pdf

latest-saprouter.png

following error:
/sapgenpse get_my_name -n validity get_my_name: no PSE name supplied, SSO credentials not readable for you! running seclogin with USER="apdadm" 0 (LPS:OFF): CN=sap1apde, OU=0000390006, OU=SAProuter, O=SAP, C=DE (LPS:OFF): /usr/sap/saprouter/local.pse NOT readable for apdadm NO readable SSO-Credentials available (total 1)

0

If the saprouter is configured with SNC, you need to configure the saprouttab with the distinguished name. Once you have generated the certificates, you need to start the saprouter with the distinguished name.

0
Former Member

can you please elaborate steps..?

Thank you:)

0

The document you have supplied has the information related to configuration of saprouter with SNC. The distinguished name is something provided by SAP when you register the saprouter with them. If you know the distinguished name then follow the document to configure the sarouter. Once done start the saprouter.

0
Former Member
Reagan Benjamin

after successful implementation of new saprouter I'm still getting error

Thu Jul 20 12:01:32 2017
SAP Network Interface Router, Version 40.4

Thu Jul 20 12:01:33 2017
***LOG Q0I=> NiPConnect: 127.0.0.1:3299: connect (79: Connection refused) [nixxi.cpp 2896]
*** ERROR => NiPConnect: SiConnect failed for hdl 1/sock 3
(SI_ECONN_REFUSE/79; I4; ST; 127.0.0.1:3299) [nixxi.cpp 2896]
*** ERROR => RTADMINREQ::sendAdminReq: NiBufConnect failed (rc=-10) [nirout.cpp 7272]

*****************************************************************************
*
* LOCATION SAProuter 40.4 on 'sap1apde'
* ERROR partner 'localhost:3299' not reached
*
* TIME Thu Jul 20 12:01:33 2017
* RELEASE 720
* COMPONENT NI (network interface)
* VERSION 40
* RC -10
* MODULE nixxi.cpp
* LINE 2896
* DETAIL NiPConnect: 127.0.0.1:3299
* SYSTEM CALL connect
* ERRNO 79
* ERRNO TEXT Connection refused
* COUNTER 2
*
***************************************************************************

Thank you :)

Best regards,

vikas kandukuri

0
* ERRNO TEXT Connection refused

Either the saprouter is still not running, or there is something (a firewall?) blocking the connection at the server itself (since we see that the server tried to connect to the saprouter at the "localhost").

0
Former Member
Isaias Freitas

since I spoke with network admin there is no firewall blocking

I think it should be a problem with saprouttab

SAProuter Name Distinguished Name (Parameter for SAPGENPSE) Target (on SAP-side) sap1apde CN=sap1apde, OU=0000390006, OU=SAProuter, O=SAP, C=DE sapserv3

Can you please tell saprottab should be like from above information

Thank you

vikas

0

For information about the saprouttab file, read the PDF file attached to the SAP Note 30289.

0
Former Member
Isaias Freitas

Before my saprouttab was like this and worked nice

P * * *

P * * ftp

P * * sftp

P * * ftp-data

P * * 22

suddenly don't know how it stoped working..

0
Show more comments
Former Member
Isaias Freitas

thank you @Isaias Freitas

Problem is solved

I deleted everything and re-installed saproutre and now it workes fine

thank you very much for you support :)

0
Show more comments