Skip to Content
0

Reference older UI5 lib version in SAPUI5 Project deployed to SAP system by WebIde

Jul 13, 2017 at 07:33 AM

32

avatar image
Former Member

Hi,

I'm developing some new SAPUI5 Projects via WebIde that are deployed on SAP system having older SAPUI5 libraries.

When I deploy to SAP I get an error saying that UI5 lib version in WebIde is greater that the one in SAP system and I have to set an older UI5 version in WebIde project.

These my concerns:

1) Can I install more version of SAPUI5 libraries on SAP Server?

2) Can these different version be referenced specifically from single projects? I mean older projects pointing to older UI5 libs and newest to more recent ones.

3) How does it work on SAP deployed projects the pointing to SAPUI5 libs? In WebIde I've a relative URL to a UI5 source in a folder of my project .. I think that after deployment it is routed in some way to the UI5 libs actually installed in SAP system is it correct?

Thank a lot in advance

Massimo

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Jul 13, 2017 at 08:33 AM
0

Hi,

I answer to myself to questions 2) 3) .. : obviously target SAPUI5 lib version is specified in manifest.json.

.. so the open question is only 1): Can I install and keep more version of SAPUI5 libraries on SAP Server?

Tnx

Massimo

Share
10 |10000 characters needed characters left characters exceeded