Skip to Content
1

Universe disappears when creating new connection/ dashboards can't connect to BI Launchpad.

Jul 13, 2017 at 07:31 AM

1.3k

avatar image
Former Member

Hi All,

I am facing below issues, please provide any solution for this

1) In BO 4.2 SP4, while creating new connection in universe design tool, the universe closes automatically. But working fine with already existing universes (previously used BO 4.0 sp04).

2) we are using dashboards 4.0 SP6, when we installed BO 4.2 SP4.. dashboards is not showing any option to connect to BI launchpad.

Thanks in advance,

Regards,

Mahesh

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
avatar image
Former Member Jul 27, 2017 at 02:38 PM
2

I was having the same issue with 4.2 SP04.

2467204 - Universe Design Tool crashes while creating a new Connection

Reproducing the Issue

  1. Login to Universe Design Tool.
  2. Click on Connections.
  3. Create a new connection. Enter the name for the connection and click on next.
  4. Universe Design Tool crahses.

Solution

Cause: Universe Design Tool crashes as JNI bridge is not loaded properly.

Steps to workaround:

Whenever a new connection has to be created, please perform the following.

  1. Navigate to <Install DIR>\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer directory
  2. Open cs.cfg and disable JNI by modifying line <Capability Name="Local" EnableJNI="Yes" Active="Yes"/> to <Capability Name="Local" EnableJNI="No" Active="Yes"/>
  3. Save the File
  4. Restart Universe Designer Tool. Click on connections and create the required number of New Connections.
  5. Reopen the same cs.cfg file from<Install DIR>\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer directory
  6. Now Re-Enable JNI by modifying the line <Capability Name="Local" EnableJNI="No" Active="Yes"/> to <Capability Name="Local" EnableJNI="Yes" Active="Yes"/>
  7. Restart Universe Design Tool.

The "Support Packages & Patches" section will be populated with the relevant patch levels once they are released.

Development Team is investigating the issue and the fix should be available in the next available patch.

For Business Intelligence Platform maintenance schedule and strategy see the Knowledge Base Article 2144559 in References section

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Jose Vasconcelos,

The solution provided is working fine as you said. But without changing to yes, I can create reports and export to launchpad. Is it necessary to change back to (EnableJNI="Yes") in cs.cfg file?

Did you had any issues with the dashboard after installing BO 4.2 SP4?

I am facing issue while opening (xcelsius-1.png). When I reinstall Dashboards it shows error(xcelsius-2.png).

Thanks for your solution :)

Regards,

Mahesh

xcelsius-1.png (12.7 kB)
xcelsius-2.png (28.8 kB)
0
Arijit Das Jul 13, 2017 at 08:02 AM
2

On point 2: you are supposed to use client versions same as server components. I have not used BIP 4.2 SP04 yet, but as per my understanding, older client tools are not supposed to connect to BIP 4.2 SP04 due to updated cryptographic libraries. Check:

https://blogs.sap.com/2017/05/18/sap-businessobjects-bi-4.2-sp04-security-updates/

Share
10 |10000 characters needed characters left characters exceeded
Prithviraj Rajpurohit Jul 13, 2017 at 08:53 AM
0

Hi Mahesh,

Check if turning off windows firewall is helping you in the point 1

For Designer you need 5 ports to be open :

- CMS 2 ports

- Input FRS

- Output FRS

- Connection Server

Also go through below sap note 2141387 - Universe Designer freezes when creating a new connection or modifying an existing one

Regards,

Prithviraj

Show 5 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Prithviraj Rajpurohit,

Thanks for repling on time.

We turned off the firewall, but it doesnot work for me(Tried with Administrator account).

0

Hi Mahesh

Did you happen to read the sap note 2141387. Did that help?

Regards

Prithviraj

0
Former Member
Prithviraj Rajpurohit

I read the sap note 2141387, No it was not useful for me. Trying for another ways still.

0
0
Former Member
Prithviraj Rajpurohit

Hi Prithviraj Rajpurohit,

Thanks.

The second link relates to the issue exactly. I have checked event viewer and I couldn't find any solution. I tried reinstall also but no use.

https://archive.sap.com/discussions/thread/3646568

Regards,

Mahesh

0
avatar image
Former Member Jul 14, 2017 at 09:07 AM
0

HI Mahesh,

Try to create a local connection first. If the local connection itself has issues then you need not look at the BO server.

And since the UDT crashes, would suggest you to check your event viewer for application logs. That should give some idea.

-Abhilasha

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Abhilasha Patil,

Iam unable to create new connection in udt, but able to create new universes with old connections. I will look into event viewer.

0