Skip to Content
0

SQL Anywhere 17 oData Failing to Start

Jul 11, 2017 at 08:31 PM

118

avatar image

Hi Folks, I have recently downloaded version 17 of SQL Anywhere and am trying to start/use the oDataSalesOrder sample that comes bundled. There is a start_server.bat file to start the dbsrv and also the oData service. The problem is when I try to start it, I get the following:

I. 07/11 16:22:20. Disconnecting shared memory client, process id not found I. 07/11 16:22:20. Disconnected SharedMemory client's AppInfo: IP=192.168.1.101;HOST=Scott-PC;OSUSER=Scott;OS='Windows 8.1 Build 9600 ';EXE=C:\sapjvm_7\bin\java.exe;PID=0xe24;THREAD=0x14bc;VERSION=17.0.4.2053;API=iAnywhereJDBC;TIMEZONEADJUSTMENT=-240 E. 07/11 16:22:20. Cannot start OData: the OData server returned an invalid response

Anyone have any idea on what I could try here? So far, I have tried changing the ports thinking there might be a port issue but it has not really helped :-(

Thanks a bunch for any help you can provide.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Robert Russell Jul 12, 2017 at 05:46 AM
1

Hi Scott,

I noticed you have SAP JVM at version 7 "EXE=C:\sapjvm_7\bin\java.exe", I only ever use Java at version 8 (not from SAP).

I do have SAP JVM at 7 and 8 so I did a quick change pointing JAVA_HOME and PATH to pick up SAPJVM 7 and experience the same error you get.

07/12 06:25:23. Disconnected SharedMemory client's AppInfo: ;......';EXE='C:\Users\Robert Russell\DownloadingLocal\sapjvm-7.1.047-windows-x64\sapjvm_7\bin\java.exe';PID=0x1ca4;THREAD=0x1fbc;VERSION=17.0.4.2053;API=iAnywhereJDBC;TIMEZONEADJUSTMENT=60 E. 07/12

06:25:23. Cannot start OData: the OData server returned an invalid response


I switched to SAP JVM 8 and it started, although I have switched back to my original Java 8 version now.

So I would suggest you try Java 8.

Regards

Robert

Show 3 Share
10 |10000 characters needed characters left characters exceeded

...although according to the docs, a version 7 JVM should be sufficient:

All samples require Java SE version 7 or later.
0

Thanks for that addition Volker, I was searching for the official statement about Java 8 from the official docs. So I only suggested trying it.

Checking Jetty version 9.3.7 (which is used for OData) and it indicates Java 1.8 (8) is required

https://wiki.eclipse.org/Jetty/Starting/Jetty_Version_Comparison_Table

0

Hm, then the doc situation seems somewhat unclear, unless the "Java 7" note relates to OData in general and Java 8 is required for the builtin Jetty server... – Note, I have not tried to use those samples myself.

BTW, SQL Anywhere comes with a JRE 8 itself for its own administration tools, so it certainly reasonable to use that with the samples...

----

It might be helpful to ask that question on the separate SQL Anywhere Forum, where usually way more SQL Anywhere folks will listen...

0
Koichi Ogawa
Jul 12, 2017 at 01:48 AM
0

The oData server(Java) seems to have stopped for some reason.
Please see the oData server log file(SalesOrdersLog.txt).

Share
10 |10000 characters needed characters left characters exceeded
Scott Dillon
Jul 12, 2017 at 04:03 PM
0

Hi Russell, you are 100% correct. I switched out the JDK and voila, that particular problem has been solved. Now I have an issue with the cloud connector that I will post shortly as well. Thanks for taking the time to investigate for me, really appreciate it.

Share
10 |10000 characters needed characters left characters exceeded