Skip to Content

Depreciation key '0000' not depreciating to '0' amount

Hi All

We have an asset which was incorrectly depreciated in month of June. Since client is not interested in manual correction we decided to go with repeat depreciation with depreciation key '0000'.

depreciation-before-changing-depreciation-key.jpg

However once we change depreciation key to '0000' & run depreciation in repeat mode it is adding around 14k $ to 7th month & subsequently for posting to 6th month. We want to make it '0'.

depreciation-after-changing-depreciation-key-to-00.jpg

depreciation-run-in-repeat-mode-after-changing-dep.jpg

Can someone suggest how to correct the issue?

Regards

Pankaj

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jul 14, 2017 at 11:30 AM

    Hi Pankaj,

    It seems the system is behaving in a correct manner. The total depreciation upto Period 6 comes to 14310.87 and the same has been proposed to be reverted after you change the Depreciation key to '0000'. As we know, whenever the depreciation key is changed, system considers the value posted upto the current period and recalculates depreciation accordingly and in this case its calculating correctly.So what is the error ?

    Now, coming back to Period 6 depreciation, if the posted value is not correct then please try the below in your sandbox system and verify the results.

    1. Change the Dep key to 0000 and run the depreciation. You will have net dep value as 0 now.

    2. Change to the Original Dep key and then run depreciation for next period. You should get back the correct value for the entire period (i.e. upto period 7)

    Please keep posted your observations.

    Best Regards

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pankaj,

      I assume that the depreciation key 0000 has no depreciation hence It'll first add 14k so that the net depreciation comes to zero. It is displayed in your Test run screenshot (49289). After that please change the depreciation key to your original one and run depreciation. System should calculate the whole depreciation for all the periods.

      Hope it helps.

      Best Regards

      Ramesh