Skip to Content
avatar image
Former Member

Error importing Idoc - Unable to read segments

Hi experts,

I have some problems importing a custom built IDoc in IR.

The error I got was:

ZPATINFO_IDTY.ZPATINFO: Error

+Error: IDoc type ZPATINFO contains error (unable to read segments)

Import failed with 1 error.

I've tried to import standard IDocs and they were successful.

I tried to import the metadata in IDX2, and was successful. A popup saying "unable to read segment versions" but i could still see the structure in IDX2.

I've added roles to my user:

SAP_BC_MID_ALE_DEVELOPER

SAP_BC_MID_ALE_IDOC_ADMIN

SAP_BC_MID_ALE_IDOC_DEVELOPER

Please help.

Thanks!

Ron

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Jun 12, 2007 at 07:13 AM

    First of all check if you have the proper authorizations;

    From Note: 837595

    Authorization object S_RFC

    Field name RFC_TYPE value FUGR

    Field name RFC_NAME value EDIMEXT, SDTX

    Field name ACTVT value 16

    Authorization object S_IDOCDEFT

    Field name ACTVT value 03

    Field name EDI_CIM value ' '

    Field name EDI_DOC value TXTRAW01

    Field name EDI_TCD value WE30

    Authorization object S_CTS_ADMI

    Field name CTS_ADMFCT value TABL

    Authorization object S_TABU_DIS

    Field name ACTVT value 03

    Field name DICBERCLS value

    Then check if the idoc and its segments have been released in R3.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 06, 2015 at 05:38 AM

    Hi Vijay Kumar

    Iam faceing same error while importing the structure from ECC system

    idoc type:BUPA_INBOUND_MAIN_SAVE_01

    error: IDoc type  BUPA_INBOUND_MAIN_SAVE_01 contains error (unable to read segments)

    Add comment
    10|10000 characters needed characters exceeded

    • Hi ,

      Check in ECC system whether all segements of that IDOC are released.

      If you are sure all segments are released then cross check each data elemnt used for that IDOC .

      Last time when i faced this issue it was found that problem was with data element.

      Data elemt was not their in a system .so it would be better if you cross check everything.

      Manoj

  • Feb 06, 2015 at 07:51 AM

    Hi Manoj

        I cheked all segments and dataelements. but the problem was not solved

    all the segments were in released state and that to all data elements were in active.

    I want to know that how to find dataelement is existing or not in their system

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      In case you are sure all segements/Data element are active better chekc the roles as mentioned in above.

      Did u try importing other IDOC ?are they succesfull ?? if not, then that would be a role problem. if yes, then you need to check particulary this IDOC,

      In ECC system you can check data element in SE11.

      Br,

      MAnoj