Skip to Content
avatar image
Former Member

BizTalk SAP Adapter 2.0 SP1 requires SAP .NET connector runtime 1.2.3

Hi,

according to Microsoft MSDN article (see below) I'm supposed to find SAP .NET Connector version 1.2.3 at Service Marketplace. I have been there, BUT cannot find such a version (only 1.03 and 2.01).

Any advice?

MSDN article: http://msdn2.microsoft.com/ja-jp/library/aa578593.aspx

Regards Torstein

=================================

Download the SAP .NET Connector runtime 1.2.3 from SAP Service Marketplace Web site. The connector will be displayed as version 1.2.0.

You can use the Adapter’s design time components with only the .NET connector runtime installed. You can install the design-time as well, but it is not required.

Not Supported:

SAP .NET connector 2.0. This version is available only as a Visual Studio add-in and is not distributed as a runtime library. Since Visual Studio is not typically available on production servers and other BizTalk Server installations, the adapter supports only version 1.2.3. This version is available as an add-in and as a runtime library.

Side by side installation of SAP .NET connector 2.0 and SAP .NET connector 1.1.

警告

SAP .NET connector versions newer than 1.2.3 are not supported by the SAP Adapter. Installing newer versions side-by-side with version 1.2.3 is also not supported by the adapter.

==================

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jun 06, 2007 at 04:07 PM

    Hello Torstein,

    you need to have the .Net Connector runtime version 1.0.3 installed (download at https://websmp108.sap-ag.de/~sapidb/011000358700004248302004E/SetupRuntime.ZIP) installed. The adapter is not working with version 2.0.1. Installation of the runtime is enough, you don't need the design time components for working with the BizTalk Adapter for SAP.

    Thanks,

    - Juergen

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 07, 2007 at 08:49 PM

    HI Torstein,

    I suggest to avoid using the sap adpater 2.0 as microsoft will not going to support it. Webservices is the best way to deal with that.

    regards

    Ram

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Ram,

      that's true, the SAP Connector for Microsoft .NET Design Time component does not support VS 2005. The runtime however is still supported. Since the BizTalk Adapter only uses the runtime it can still be used in VS 2005. SAP will not provide a new connector which works with VS 2005, instead of a new connector SAP will ship the ES Explorer with the next version of the Portal Development Kit, they had several presentations at SAPPHIRE about this topic.

      Microsoft also developed a new set Line-of-business System adapters including SAP based on WCF, this adapters are currently in Beta and Microsoft applied for certification at SAP.

      Thanks,

      - Juergen