Skip to Content

SEM BCS:No data has been read from the source data stream

Hi,

I am executing datacollection task through load from data stream. System is giving an information message No data has been read from the source data stream - Message no. UCF7033. We are on BI 7.0 and SEM 6.0.I am able to see data in Source Infocube FIGL_C10 in BW. But SEM is unableto retrieve the data.

Looking forward for your help.

Regards

Sreekanth elkuri

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

7 Answers

  • Posted on Jul 23, 2007 at 08:03 AM

    Sreekanth,

    Don't get me wrong. I'm just trying to understand what was wrong in your case and what has cured this.

    Since it should be interesting for many BCSers, I wouldn't like to hide all details in a private chat. I prefer to keep it open.

    So, let's consider the situation from the higher level.

    The data basis always has the VERSION Role. As I mentioned before, the default value for the VERSION is 100.

    This Version role <b>(in BCS) </b>is mapped in the mapping rules of datastream method with incoming <b>from BW</b> infoobject. If not customized, it's the 0CS_VERSION infoobject. And regardless of incoming version values, the output values of version must be meaningful for BCS values, i.e. 100, 200 etc.

    The BW-system doesn't care what values came to 0CS_VERSION and from which sources. The value may come from R/3 (something like your ECC version) or from the flat file or whatever.

    So, I don't see where your 0 or 1 version do fit.

    ECC version -- is it located in R/3? Since the BCS is fed from BW and expects meaningful for itself version values (like 100 or 200), where is a place for version like 0 or 1?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Elkuri Sreekanth

      Folks,

      It is NOT necessary to map BCS version to anything from ECC. Period. Whether you need to do that totally depends on how you are staging your incoming trial balance. Remember, there are more than one ways to skin this cat. There is no requirement for anyone to map 0CS_VERSION from BCS to anything from ECC or anywhere. For all you know, you could use a constant '100' or something similar. So, I am not sure all this discussion about mapping version to 0 or 1 doesn't in the least bit make sense. Granted, that might have solved your problem in this particular case. But, that is not the problem. The problem lies somewhere else. If you use a constant, it might give you a warning about the version or something similar but it shouldn't prevent you from loading your data.

  • Posted on Jul 20, 2007 at 07:23 PM

    Interesting, you know how to close the thread as solved by yourself and didn't grant any points to anybody. Wow! Superb! It's THE ATTITUDE!

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 23, 2007 at 07:26 AM

    You lost me completely.

    What is ECC Version?

    What the tech. name of this infoobject?

    Is it a field coming from the data stream?

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 06, 2007 at 05:59 AM

    Hi,

    In my experience I had this problem when there were several infoobjects with the role Version in my totals cube. Since the ROLE in BCS is a concatenantion/compounding of the infoobject values having this role, the system couldn't assign the proper BCS Version to incoming from the source cube data.

    Another obvious culprit is the wrong mapping in the reading from datastream method.

    Best regards,

    Eugene

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Jul 18, 2007 at 03:37 PM

    May be you already have, but there is an OSS Note which talks about this problem with respect to release 6.0. Kindly read and see if it is applicable to you:

    "Note <b>953173</b> - <i>No data has been read when executing data stream load method</i>"

    Let me know if it helps.

    Lalit

    Add comment
    10|10000 characters needed characters exceeded

    • Lalit,

      Thanks for the reply. This issue has been resolved sometime back. I was just going through the note u mentioned, this note is not applicable for us as we are ahead of this support pack.

      Rgds

      Sreekanth

  • Posted on Jul 19, 2007 at 02:17 PM

    So, what was the remedy?

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 20, 2007 at 07:11 PM

    In my first reply I mentioned about possible problems with Version Role.

    You marked this thread as answered by yourself and after my request for clarifications vaguely answered that the problem was with the version role.

    I don't care about points, but for the sake of the community please answer what exactly was the problem and what was the remedy!

    Add comment
    10|10000 characters needed characters exceeded