Skip to Content
author's profile photo Former Member
Former Member

Problem with i_step = 3 and message output in WAD template

Hello experts,

we experience a "funny" problem with our variables user exit in connection with WAD. In the exit step i_step = 3 (include ZXRSRU01) we create error messages using message class RSBBS depending on particular value combinations of the exit variables. Everything works fine in BEx query AND in the WAD template in DEV system -> the error messages are displayed in top of the selection dialogue, that's ok. But in PROD ONLY the messages in BEx work fine, NOT in the WAD template!

We have no idea what's missing during transport from DEV to PROD. What could it be? It has to be something concerning WAD...

Any help is appreciated, points will be rewarded

Regards

Thilo Krawietz

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jun 07, 2007 at 11:09 AM

    <FONT FACE = "Tahoma", Font Color = "Blue">

    Hi<br>

    Please debug the query in PROD using Transaction RSRT and Query Display as HTML.

    <br><br>

    Hope it helps.<br>

    Cheers Abhijit</FONT><FONT FACE = "Verdana", Font Color = "Red">

    <br>

    • It's a good habit to reward someone with points in SDN if you think his/her

    response was helpful to you

    </FONT>

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Nirav,

      in WAD 3.5 template:

      - you disable warnings by adding the following line in the object tag TEMPLATE PROPERTIES (in HTML tab):

      <param name="SUPPRESS_WARNINGS" value="X"/>

      The same effect is achieved when you check the checkbox "Do not display warnings", which is the 4th entry in the template properties box (left bottom in WAD window) in the web item tab.

      in WAD 7.0 template you can disable warnings in the xhtml tab by adding the code line

      <bi:WARNINGS_VISIBLE value="" />

      in the section:

      <bi:TEMPLATE_PARAMETERS name="TEMPLATE_PARAMETERS" >

      </bi:TEMPLATE_PARAMETERS>

      or in the left bottom properties box (only visible when layout tab is active) by unchecking the entry "Warnings visible" under section "Internal display"

      I hope this helps you!

      cheers,

      Thilo

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.