Skip to Content
avatar image
Former Member

Langaugae override problem

Hi Team

I am a SD consultant posting my technical problem below, pl address this.

Scenario:

We have orders getting creating with message type ORDERS with basic type ORDERS02 as an Inbound IDoc.Suppose if an Idoc failed it triggers corresponding user an workflow (Reasons for failure might be wrong customer or inputvalues are worng) then these users create Idoc in foregorund.

Problem:

Whenever Idoc created in back ground ie without any problems Item text is set to langauge DE ( Segment for this used E1EDPT1).

Whenver if we re process the error Idoc in foregorund its language set for one of the text ids is always EN.

Why this is happening?

Analysis:

I did two scenarios:

1. Using my default log on language EN.

When i re process error IDOC in foreground Item text language set was EN.

2.Changed my log on langauge to DE.

When i re process Error Idoc in foregorund this time Text language set was DE.

Hence we thought that langauge E1EDPT1-TSPRAS comes from the userid language from table USRS03 or from log on language.

Uid used :100998

Table USRS03 Language:EN.

But for the same user id if all data is correct created in background successfully langauge set was DE. So its not coming from USRS03 table or from log on langauge.

Can any one give me hints for this typical issue? Its impacting a lot for many Idocs and causing a big crook for my German users.

FYI:

I just got to see this field E1EDPT1-TSSPRASISO = your text ISO code if different form your language, generally they are the same.

What is this and where to see this ?

Pl advise

Reg

Shan124

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 05, 2007 at 07:20 AM

    Hi Shan

    You have solved the problem almost.

    In background mode, you have the option to define even the language in which the job has to run. So in bgrd mode, always it gets executed in DE.

    However in foreground mode, only teh user ids logon will be taken into account. Hence based on ur logon language, the IDOCS will be triggered.

    This is a universal problem in any IDOCS, output types.

    To solve this, we have done some coding in the output types to reset the user logon language based on certain parameters maintained in a ztable.

    Also another factor which can come to picture is not the user language, but the system language (SYLANG). This should also be taken into account when you are analysing this issue.

    Based on the analysis, you should either always process IDOCS in background mode with DE as language maintained in transaction code SM36(when u r configuring the background job), or if you want to trigger this IDOC in foreground mode, then you have to somehow manipulate either the user language or the SYLANG or both based on your scenarios.

    Reward point if it helps.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 05, 2007 at 07:29 AM

    Hi,

    Check if you have maintained translation for that particular text ID.

    Hope this will help.

    Regards,

    Naveen.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      HI

      IIM Nava thanks for your valuable response. I tried to find any OSS notes for this but could not find any for 4.7 version.

      So the only option now is to log on with different languge if wanted to process in foreground.

      Naveen

      Whats ment by Translation for text ids where this is maintained?

      Reg

      Shan1242