Skip to Content
Former Member
Jun 04, 2007 at 06:45 PM

dbua Can't connect to X11 window server using ''


Upgrading Oracle on Solaris 10 to Oracle on a BW 3.0b system

Hello, I am in the process of upgrading Oracle on a Solaris machine. I am trying the upgrade from my windows XP pc. I have an X server running on my pc. I’ve tried using both shells csh/ksh and I have all my env variables set. I can run /usr/openwin/bin/xlogo just fine, I've even just finished upgrading the server from to using runInstaller just fine. Yet dbua can not connect to my PC. I've even tried running dbua on a Sun Blade 100 machine (after typing xhost +) and I get the same error. I am very perplexed. I’ve searched the forms and seen similar errors but I can not find a solution.

The Display variable is set properly.

Here's the specific error:

sapapp:orabwp 7% cd /oracle/BWP/102_64/bin;./dbua

Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using '' as the value of the DISPLAY variable.

at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)

at sun.awt.X11GraphicsEnvironment.<clinit>(

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(

at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(

at java.awt.Font.initializeFont(

at java.awt.Font.<init>(

at oracle.ewt.lwAWT.LWComponent.<clinit>(Unknown Source)

at oracle.sysman.assistants.util.wizard.WizardObject.<init>(

at oracle.sysman.assistants.dbma.ui.DBMAWizard.<init>(

at oracle.sysman.assistants.dbma.ui.UICompManager.<init>(

at oracle.sysman.assistants.dbma.Dbma.getCompManager(

at oracle.sysman.assistants.dbma.Dbma.execute(

at oracle.sysman.assistants.dbma.Dbma.statusMain(

at oracle.sysman.assistants.dbma.Dbma.main(